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Preface

About this Guide
This guide is designed as a step-by-step guide as well as a useful reference. It introduces to analysts the major features of Brio.Insight. 

The lessons in the guide are illustrated with various screen captures to help illustrate the concepts. By the end of the lessons, users will be able to:

· manipulate pre-built queries and reports

· create a variety of report styles, including cross tabs, charts, tabular, and free-form

· analyze data in the Pivot and Chart sections

· create queries using data models

Lessons

The lessons in this guide are designed for analysts of FPPS data and anyone else who queries databases and builds reports. Although intended for Brio.Insight beginners, the lessons assume a familiarity with Windows basics, such as choosing menu items and using a mouse.

Each lesson begins with an overview of its key terms and learning objectives.

Each concept is described and illustrated with an example, and then instructions on how to perform various tasks associated with the concept follow.

Lessons are as follows:

Chapter 1 Introducing Brio.Insight

· Lesson 1: Brio Client Overview

· Lesson 2: Accessing the Document List

· Lesson 3: Navigating the Interface

· Lesson 4: Basic Document Manipulation

Chapter 2 Creating Queries from Pre-built Data Models

· Lesson 1: Query Fundamentals

· Lesson 2: Aggregating Queries

· Lesson 3: Importing Data Files

Chapter 3 Results and Table Sections

· Lesson 1: Working in the Results Section

· Lesson 2: Creating Tabular-Style Reports

Chapter 4 Pivot Section

· Lesson 1: Creating Pivot Reports

· Lesson 2: Analyzing Pivot Data

Chapter 5 Chart Section 

· Lesson 1: Creating Charts

· Lesson 2: Analyzing Chart Data

Chapter 6 Report Section
· Lesson 1: Creating Free-Form Reports

· Lesson 2: Preparing Reports for Printing
Appendix A is a glossary of terms.

Appendix B lists database and internal functions used in computed items.

Appendix C provides information about Print Preview mode.

Appendix D provides information on creating Computed Items.

Formatting Conventions

This guide includes special formatting conventions to use it more effectively:

Text - When a menu bar is referenced, text is highlighted in bold. Key terms are

italicized.

IMPORTANT - This format indicates an important or key point.

NOTE - Indicates reader take note. Notes contain helpful suggestions or

technical information not discussed in the body of the text.

TIP - A suggestion or useful shortcut for carrying out common tasks.

BrioQuery File Formats

Brio.Insight works with BrioQuery document files with a *.bqy file extension. In this guide, BrioQuery documents are referred to as “documents”. It is not required to be familiar with Brio.Insight before using this guide.

Available FPPS Files and Descriptions for Brio Queries

Data that can be queried through the Brio reporting tool is contained in various files.  It is extremely helpful for Brio users to have a thorough understanding of these files in order to efficiently and effectively use Brio and to understand the data returned from each query. A complete list of available files can be found at the Datamart Web page, under “File Descriptions”. As an example, the FPPS Combined File Data provides a current “SNAPSHOT” of the employee personnel and payroll record.  The personnel records are updated nightly and the payroll records are updated bi-weekly after pay calculate. 

Use this file to produce reports with current employee information such as grade, step, occupational series, type of appointment, leave balances, position occupied, etc.

Security

Brio.Insight maintains the data integrity of FPPS.  Users will only be able to access records within their range of authority as defined in FPPS.  The Security Point of Contact (SPOC) for your agency has the responsibility for establishing and/or changing your range of authority in FPPS.

Minimum System Requirements XE "System Requirements" 
Computer/Platform:

Windows/Intel-based PC

Operating System:

MS Windows 

Hard Disk:


10 MB

RAM:



32 MB

Monitor:


Color or Gray-Scale

Web Browser:

Microsoft Internet Explorer 4
Connectivity:


Connected to NBC, Products and Services

Chapter 1 Introducing Brio.Insight XE "Brio.Insight" 
This unit provides the background information about Brio.Insight.  Upon completion of this unit users will be able to:

· Identify the following key terms:

· Business intelligence

· World Wide Web (WWW)

· Plug-in and Stand-alone Application

· Internet, Intranet, and Extranet

· Brio.Insight

· OnDemand Server

· Adaptive Report level

· Zero Administration

· File Server

· Locked Data Model

· Auto Processing

· Variable Limits

· Identify Brio.Insight

· Understand the five (5) Adaptive Report levels

· Navigate and connect to an OnDemand Server

· Install Brio client software

· Navigate the Brio client interface

· Navigate and use Brio Online Help

· Execute common keyboard commands

· Understand how documents can be stored

· Understand locked data models

· Utilize the limit prompt in order to tailor reports

· Open documents without an OnDemand Server

· Save and close documents

· Disseminate reports via:

· Printing

· Exporting (same or different file format)

· Copying to the clipboard

Lesson 1: Brio Client Overview
Lesson Objectives

Upon completion of this lesson users will be able to:

· Identify the following key terms:

· Business intelligence

· World Wide Web (WWW)

· Plug-in and Stand-alone Application

· Internet, Intranet, and Extranet

· Brio.Insight

· OnDemand Server

· Understand the five (5) Adaptive Report levels

Business Intelligence XE "Business Intelligence" 
Success in today's fast-paced, extremely competitive business environment depends on an organization's ability to utilize the information in its various operational systems, data marts or data warehouses. With the right data in the right hands, organizations can improve business processes, enhance customer service, accelerate sales and increase profitability. The key to addressing these and many other critical business issues is establishing an infrastructure which delivers valuable information to end users for timely, informed decision-making. Many successful organizations are realizing value by delivering enterprise business intelligence through an integrated information supply chain that links

information producers with information consumers.

For decades, IT (Information Technology) organizations have supported knowledge workers by providing information in the form of "canned" reports and analyses. Although many organizations have empowered users with more direct access to corporate data, the vast majority of users are still dependent on IT. Successful enterprise business intelligence dramatically changes this dependency. It creates an environment where IT can effectively supply information and the right business intelligence tools to diverse users while decreasing their own report backlog and overall support burden.

This new supply chain relationship can allow IT to leverage its strengths in database management, security, infrastructure maintenance, report writing and distribution while empowering knowledge workers to focus on answering business questions on their own.

World Wide Web (WWW) XE "World Wide Web:World Wide" 

 XE "World Wide Web:World Wide Web (WWW)" 
The World Wide Web is a system of Internet servers that support specially formatted documents. The documents are formatted in a language called HTML (Hypertext Markup Language) that supports links to other documents, as well as graphics, audio, and video files. This means you can jump from one document to another simply by clicking on hot spots. Not all Internet servers are part of the World Wide Web.

There are several applications called Web browsers that make it easy to access the Web. Brio.Insight works with Netscape Navigator and Microsoft's Internet Explorer.

Plug-in XE "World Wide Web:plug-in" 
A plug-in is a special application file placed in a browser’s Plug-in directory.  Plug-ins add seamless functionality to a Web browser, enabling the browser to open a plug-in’s particular file type. For example, Brio.Insight is available as a plug-in and enables browsers to open BrioQuery documents.

Stand-alone Application XE "World Wide Web:stand-alone application" 
A stand-alone application is independent of a browser. It can be any application commonly used to open a particular file type. The application is associated with a browser and assists it by automatically opening a file type, which the browser cannot open on its own. Brio.Insight is available as a stand-alone application.

Internet XE "World Wide Web:Internet" 
The Internet is a global network connecting millions of computers. Unlike online services, which are centrally controlled, the Internet is decentralized by design. Each Internet computer, called a host, is independent. Its operators can choose which Internet services to use and which local services to make available to the global Internet community.

Intranet XE "World Wide Web:Intranet" 
An intranet is a network based on TCP/IP protocols belonging to an organization, usually a corporation, accessible only by the organization's members, employees, or others with authorization. An intranet's Web sites look and act just like any other Web sites, but the firewall surrounding an intranet fends off unauthorized access. Like the Internet itself, intranets are used to share information. Secure intranets are now the fastest-growing segment of the Internet because they are much less expensive to build and manage than private networks based on proprietary protocols.

Extranet XE "World Wide Web:Extranet" 
An extranet refers to an intranet that is partially accessible to authorized

outsiders. Whereas an intranet resides behind a firewall and is accessible

only to people who are members of the same company or organization, an

Extranet provides various levels of accessibility to outsiders. Extranets are

secured by user names and passwords. A users identity determines which

parts of the extranet he/she can view. Extranets are becoming a very

popular means for business partners to exchange information.

Brio.Insight XE "Brio.Insight" 
Brio.Insight is a plug-in that enables users to access a document list via the Web.  

Brio.Insight users can access a document list to view and refresh (process) pre-built reports, as well as access pre-built data models, create, analyze and process new reports.

The OnDemand Server XE "OnDemand Server" 
The OnDemand Server is a Web-based application server that uses pull technology to allow users to view and select from a list of available documents as well as to build and process new queries through the Web.

OnDemand Server documents may contain one or more completed reports, or they may simply contain the components that allow users to build their own queries and reports. Each document is assigned an Adaptive Report level, for pertinent groups of users, to define permissible levels of interaction with the document. Interaction levels range from simple viewing privileges to drill-down, formatting, and data manipulation capability, to authorization to build and process new queries. For example, some users may need only to view reports, not to re-query the database.  Other users may need to modify a report format to meet their specific analysis needs, and others may need true ad hoc access to the database.

Default Adaptive Report Levels XE "Adaptive Report Levels"  Groups

With Adaptive Reports, every document is tagged with an Adaptive Report level.  Below are the five Adaptive Report levels:

View XE "View"  - Allows viewing, navigation, and printing of documents. (Save, Export, and Print functionality)

View and Process XE "View and Process"  - Along with View features, View and Process allows refreshing of results by reprocessing the query over the Web. (Save, Export, Print, Schedule, and Process functionality)

Analyze XE "Analyze"  - Along with View features, Analyze allows disconnected, ad hoc analysis of retrieved documents (i.e. create Pivot, Chart, and Detail reports).

Analyze and Process XE "Analyze and Process"  - Along with Analyze features, Analyze and Process allows refreshing of the Results by processing the query over the Web.

Query and Analyze XE "Query and Analyze"  - Along with Analyze features, Query and Analyze enables users to create new queries and make changes to the query that the data model supports.

Lesson 1 Summary

In this lesson you have learned:

· Organizations are providing business users with access to company data to provide a means to help answer questions about the business and improve the overall decision-making power.

· Business users can access data in a Web environment. In a Web environment, analysts can use Brio.Insight to create queries from pre-built data models, analyze data, and create new reports.

· The OnDemand Server is a Web-based application server that uses pull technology to allow users to view and select from a list of available documents as well as to build and process new queries through the Web.

· In a Web environment, a user is assigned to a group (or multiple groups), which is assigned a default Adaptive Report level. Privileges include “View”, “View and Process”, “Analyze”, “Analyze and Process”, and “Query and Analyze”. Administrators can assign an Adaptive Report level to a document that overrides a group’s default level.
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Lesson 2: Accessing the Document List

Lesson Objectives

Upon completion of this lesson users will be able to:

· Identify the following key terms:

· Zero Administration

· Navigate and connect to an OnDemand Server

· Install Brio client software

Navigating to the OnDemand Server Web Site XE "Navigating to the OnDemand Server Web Site" 
Users access the OnDemand Server from within their browsers.

To navigate and connect to an OnDemand Server:

1. In a browser, navigate to the FPPS Datamart Web page at: https://securedatamart.nbc.gov
2. (Optional) Create a bookmark to mark the OnDemand Server Web page in the browser.

3. Click the show document list icon.
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4. A logon window appears.
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5. Enter a Username and Password, and then click the Logon button. At this point the OnDemand Server authenticates the Username and Password as valid and determines if Brio.Insight is installed on the client’s computer.  It then retrieves a list of documents for which the user has access.

Installation Procedure XE "Brio Installation Procedure" 
Once a user is authenticated by the OnDemand Server, the OnDemand Server determines if the client computer has Brio.Insight installed. If not, the user is prompted to install the product. This feature is referred to as Zero Administration XE "Zero Administration"  where an administrator does not need to be involved.

After the Brio client is installed, a user is no longer prompted to install the software, unless it has been upgraded and the user’s computer does not have the latest version. A user can then proceed to download documents from the document list.

System Requirements XE "System Requirements" 
Below lists the necessary system requirements for Brio.Insight. Browser extensions are plug-ins to the browser.  JavaScript must be enabled in the browser for Zero-Administration.

Windows, Intel-based PC

· Windows95, 98, 2000, ME, NT, or XP

· 10 MB Hard Disk

· 32 MB RAM (recommend 64 MB)

· Connectivity to NBC, Products and Services

· Color or gray-scale monitor

· Browser Extension

· Supported Web browser:

· Microsoft Internet Explorer 5.5 (w/SP2) or higher

Begin the Installation

To install Brio.Insight:

1.  Access the FPPS Datamart web page and log in.

2.  Once authenticated as a valid user, a Rules of Behavior dialog box appears.  To continue the download, read the Rules of Behavior and confirm your acceptance of the conditions by clicking the Agree button at the bottom of the screen.

[image: image2]
3.  On the next screen, select the appropriate plug-in, Brio.Quickview or Brio.Insight.  For Brio.Insight (used by the majority of licensed users), you will need to enter an unlock code which can be obtained by calling the Datamart Help Desk (303) 969-5048. For security reasons, the unlock code will periodically change.  To obtain the current unlock code, call the Datamart Help Desk at (303) 969-5048.
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4.  Click Begin to start the download and wait until you are shown a digital  

certificate asking your permission to install software. (See next step)
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5.  When the Security Warning window appears, click the Yes button to continue.
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8.  Once the upgrade is successful, click OK in the displayed dialog box.
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9.  Click the Finish button.
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10.  The document list appears in a new browser window.
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11.  To open a document, browse the folders (by clicking on the folders) and 

      then select a document.

Lesson 2 Summary

In this lesson you have learned:

· Brio.Insight is a plug-in application for Windows95, 98, 2000, ME, NT, or XP.

· Brio clients can be automatically installed using Zero-Administration.  For example, if Brio.Insight is not installed on a computer, the user is prompted to install it once he/she is authenticated by the OnDemand Server. This feature is referred to as Zero Administration because software installation and upgrading occurs automatically, without an Administrator’s help.

· Brio clients access a Web page to log on an OnDemand Server and access a document list.
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NOTES:
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Lesson 3: Navigating the Interface XE "Navigating the Interface" 
Lesson Objectives

Upon completion of this unit users will be able to:

· Navigate the Brio client interface

· Navigate and use Brio Online Help

· Execute common keyboard commands

The Interface XE "Interface" 
The Brio client interface is a tri-pane window that provides all components necessary for performing database operations. It includes the section title, the section pane, the Content pane, the Catalog pane and the Request, Limit and Sort lines.

Interface components, such as toolbars, lines, and Outliners, can be undocked by dragging the docking bar to a new location.

[image: image150.png]Bureau | sub bur

N 07 01 WESTO02 BARNETT, RANDALLY
N 07 01 WESTO19  ROYEK, RHONDAM

IN 07 01 WESTO19  ROWE, TREVANION.

IN 07 01 WESTO19 PORTELA ANA

N 07 01 WESTO19  MONTY,JEANNETTEE

N 07 01 WESTOI9 JACKSON,HORACEL

N 07 01 WESTO19  SCHUR, MARGARETA

N 07 01 WESTOI9  HARRIS, KATHLEEN K

N 07 01 WESTOI9 DEMARIA BARBARAA

IN 07 01 WESTO19  CLATTERBUCK, ARLENEA
IN 07 01  WESTOIS  CLACK ANNIE H




Once a component is undocked, it can be resized. To re-dock, double-click the top of the component.
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Below is an illustration of the interface.
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(1) Section Title Bar XE "Interface:Section Title bar" 
The Section Title bar, which is shown above the Sort line, displays the section you are currently working in.

To hide or close the Section title:

· On the View menu, click Section Title bar.

(2) Section Pane XE "Interface:Section pane" 
The Section pane, in the upper left area of the windows, lists all the sections that are available in a document.

To hide or close the Section pane:

· Click the X icon to the right of the “Section” heading.

To reopen the Section pane:

· Click the Section/Catalog icon on the Standard toolbar.

(3) Content Pane XE "Interface:Content pane" 
The Content pane, in the lower right area of the window, provides a view of the section you are using, such as the Data Model, Results or Chart.
(4) Document Sections XE "Interface:Document sections" 
· Query—Repository data models are displayed in the content area. The Request line, Sort line and Limit lines are used to create queries.

· Results—Rows of data returned from a query are stored in a table format. Data can be sorted, limited, computed, and formatted.

· Table—New tables can be created based on the rows of data stored in the Results section.

· Pivot—A cross-tab report style section where data can be analyzed.

· Chart—Bar, line, pie, area, ribbon and area charts can be created.

· Report—Free form structured reporting where multiple result sets can be displayed in one report.

To navigate to a section:

· Click the section name in the Section pane of the application. If the Section frame is not displayed, on the View menu, click Section/Catalog.

To insert a new section:
· On the Insert menu, click the section type you want to insert.

(5) Toolbars XE "Toolbars" 
Three toolbars provide quick access to frequently used features. The toolbar configuration is saved when you exit the application, and displays the same toolbars when the application is restarted.

To toggle a toolbar:

· On the View menu, point to Toolbars, and then click the (toolbar name).

(a) Standard Toolbar XE "Toolbars:Standard toolbar" 
The Standard toolbar contains commands applicable in all sections.

Buttons include: Save Brio Insight Document, Print, Print Preview, Delete, Show Section/Catalog, Insert New, Properties, Limit, Sort Descending, Sort Descending, Grand Total, Group Labels, Process, Back, Forward, Home, Help.

(b) Formatting Toolbar XE "Toolbars:Formatting toolbar" 
The Format toolbar provides text format, styling and edit commands and can be used to rename items.

Buttons include: Font Name, Font Size, Bigger Font, Smaller Font, Bold, Italics, Underline, Left Justify, Center, Right Justify, Line Color, Fill Color, Text Color.

(c) Section Toolbars XE "Toolbars:Section toolbar" 
Specific Section toolbars are available in the Chart and Report sections.

Chart Section XE "Toolbars: Chart Section" : buttons include Chart Type, Set Legend On, and Zoom.

Report Section XE "Toolbar:Report Section" : buttons include Alignment, Make Same Size, Layer, Set Spring, and Zoom.

(6) Command Lines XE "Interface:Command lines" 
The Request, Sort and Limit lines are drag-and-drop command lines that offer a visual way to complete some of the most important operations in the query and reporting process. If you hide command lines, the conditions are maintained until the command lines are displayed again and changes are made.

To toggle the command lines:

· On the Section Title bar, click (command option).

(a) Request Line XE "command lines:Request line" 
The Request line appears in the Query section and references the items in the query. Items are added to the query by dragging them from a data model to the Request line. The Request line is expandable and can wrap text to display multiple rows of request columns.

(b) Sort Line XE "command lines:Sort line" 
The Sort line tracks sort conditions applied to a data set, and allows you to specify compound and nested sorts. Apply a sort to an item by dragging a Request item to the Sort line.

(c) Limit Line XE "command lines:Limit line" 
The Limit line tracks limit constraints placed on a query. A limit can be applied to an item by dragging a item from the data model in the content area to the Limit line. A Limit line is also available in the Results and Table Sections for the purposes of filtering data locally.

(7) Status Bar XE "Interface:Status bar" 
The Status Bar is located below the content area and displays live

information about data retrieval, the connection status, and the Adaptive

Report level for the document.

To toggle the Status Bar:

· On the View menu, click Status Bar.
Outliners XE "Interface:Outliners" 
Outliners are drag-and-drop templates used in the Table, Pivot, Chart, and Report sections. Each Outliner panel corresponds to a specific layout element of the report. To create reports, drag items from the Catalog into an Outliner panel. Data appears simultaneously in the content area with the appropriate formatting. Also use the Outliner to manage a report. The Outliner lets you add, move, reorder and remove items quickly and easily.

To toggle Outliners:

· Click Outliner on the Section Title bar.

Table Outliner XE "Outliners:Table Outliner" 
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Pivot Outliner XE "Outliners:Pivot Outliner" 
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Chart Outliner XE "Outliners:Chart Outliner" 
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Report Outliner XE "Outliners:Report Outliner" 
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Selection Techniques XE "Selection techniques" 
Brio clients follow standard mouse procedure for selecting items in a series.

To select a contiguous range of items:

1. Click the first item in the range.

2. Hold the [Shift] key and click the last item in the range. The entire range of items is selected.

NOTE You cannot make contiguous item selections in the Chart section.  You have to select each chart object as discontinuous items.

To select discontiguous items:

· CTRL-click each item (Windows)
Special Selections XE "Special Selections" 
In several cases, use the modifier key to select or complete a mouse operation (for example, when selecting an individual row in Pivot reports).  The modifier key combination for Windows: Alt-click.

Menus, Speed Menus XE "Speed menu" , and Keyboard Commands

Speed menus are convenient for issuing commands “on the fly”. In addition, users can also use standard menu bar commands to perform a variety of tasks.

To use a speed menu:

1. Right-click.

2. Choose the desired command from the speed menu, or submenu.

Keyboard Commands XE "Keyboard commands" 
Keyboard commands are used in the following ways:

· Press a modifier key to make a special selection

· Press the Delete key to remove items from the display

· Scroll up and down in Results and report sections using the Page Up and Page Down keys (also use the scrollbars and mouse).

Online Help XE "Online Help" 
Brio Enterprise Online Help is an online guide to working with the Brio suite of products. The default Online Help window pops up in the upper-right corner of the screen. A vertical scrollbar is available on the window if all of the text cannot be displayed in the default open window.

To access Online Help:

· On the Main menu, click Help.

Lesson 3 Summary

In this lesson you have learned:

· The Brio client interface for the Web consists of a Section Title bar, Section pane, Content area, and a Catalog pane. Document sections include Query, Results, Table, Pivot, Chart, and Report. Toolbars include the Standard toolbar, Formatting toolbar, and Section toolbar. Command lines include the Request line, Sort line, and Limit line. Outliners are available in the Table, Pivot, Chart, and Report sections. The Status bar can be viewed in all sections.

· Brio clients follow standard mouse procedure for making contiguous and discontiguous selections.

· Users have the option to use standard menu, speed menu, and keyboard commands to perform a variety of tasks.

· Context-sensitive Online Help is available for all Brio client products.
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with the level of infraction. Actions may range from a verbal or written
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Lesson 4: Basic Document Manipulation

Lesson Objectives

Upon completion of this unit users will be able to:

· Identify the following key terms:

· Locked Data Model

· Variable Limits

· Understand locked data models

· Utilize the limit prompt in order to tailor reports

· Open documents without an OnDemand Server

· Saving and closing documents

· Disseminate reports via:

–    Printing

· Exporting (same or different file format)

· Copying to the clipboard

Locked Data Models XE "Data Model:locked" 
Documents consisting of data models for the purpose of creating queries can be locked by an administrator. This means that users cannot modify the data models in the document, but can build off of them. Administrators do this to ensure report validity.

Processing Queries XE "Processing Queries" 
Processing queries re-executes them on the database server. Queries can be configured by an Administrator to process automatically (see Auto-Processing) or need to be manually processed by the user. In order to process a query, a connection to the OnDemand Server is required.  Process queries to do the following:

· update the data in the reports

· populate the Results sections with data

· enter different limit values on the queries (see Variable Limits)

Since multiple queries can exist in a document, there are three processing options on the Standard toolbar:

· Process Current XE "Proccessing Queries:Process Current" —processes the query that is currently active.

· Process All XE "Processing Queries:Process All" —processes every query in the document.

· Process Custom XE "Processing Queries:Process Custom" —opens a Process Custom dialog box and enables the user to choose specific queries to process.

To process a query (or queries):

1. Click the Process button (or select a processing option) on the Standard toolbar.  If Process Custom is selected a Process Custom dialog box appears.  Click the check boxes beside particular queries, and then click OK.

2. In each connection dialog box, enter a Username (that is, a database user name) and Password, and then click OK.  During retrieval, the Status bar displays a dynamic row count indicating the rate and progress of database processing and network transfer.

To cancel a processing query XE "Query:canceling" :

· Simultaneously press and hold the [Alt] and [End] keys on the keyboard until the query is cancelled. (For Macintosh, press [Command]+[.(period)]).

NOTE  If the database is performing computations prior to sending the data across the network, the query can only be cancelled if an asynchronous API, such as Open Client is used.

Variable Limits XE "Processing Queries:Variable Limits" 
Queries can contain variable limits that prompt users to enter or select limit values before the queries are processed on the database. Variable limits provide query flexibility. For example, a query may prompt users to select a year value. Some users may want to look at the current year and others the previous year.

Most databases contain such large volumes of data that setting limits on queries is critical. Administrators need users to set limits on their queries; however, hard-coding the limit values does not always meet the users’ needs. Variable limits often solve the problem since users must enter limit values in the prompts, but can enter the values they need.

Opening XE "Documents:opening"  and Closing Documents

Documents can be directly opened within a Web browser, without logging into an OnDemand Server. In order to perform query functions, however, a connection to the OnDemand Server is required (see Reconnecting to the OnDemand Server).

NOTE A document opened in a browser, not connected to the OnDemand Server, has “Analyze” privileges (if Brio.Insight is installed).

If there are problems opening documents in a Web browser, follow these steps:

1. Select a BrioQuery document.

2. Holding the Shift key down, right-click, and then click Open With.

3. Select Internet Explorer or Netscape Navigator from the list of installed applications.

4. Select the check box for “Always use this program to open this type of file”, and then click OK. From this point on, double-clicking a document will open it within the selected browser.

Microsoft Internet Explorer

To open a document in Microsoft Internet Explorer (version 4.0 or higher):

1. Open Microsoft Internet Explorer.

2. On the File menu, click Open.

3. In the Open dialog box, click the Browse button.

[image: image13.png]Type the Intemet address of 3 docurent o folder, and
Internet Explerer il open t for you.

e [ ]

I~ Open as Web Eolder

=





4. In the Open dialog box, select the document, select All Files from the Files of type pull-down menu, and then click the Open button.
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5. In the Open dialog box, click the OK button. Internet Explorer opens the document using the Brio.Insight plug-in.
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Reconnecting to the OnDemand Server XE "OnDemand Server:reconnecting to Server" 
If an OnDemand Server document is opened within the browser without connecting to the OnDemand Server (as described above), the user is automatically prompted to log in to the OnDemand Server when necessary. For example, to process the queries in the document, the user is prompted to log in.

To reconnect to the OnDemand Server:

1. Perform an action that requires an OnDemand Server connection. For example, click the Process button.

2. In the OnDemand Server dialog box, enter a Username and Password to log into the OnDemand Server, and then click OK. 
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Closing Documents XE "Documents:closing" 
To close a document:

· (Plug-in) Click the X button in the upper right-hand corner of the document window. In the Brio.Insight dialog box, click the Yes button to save the document.

Saving XE "Documents:saving"  Documents

Documents can be saved locally or on a file server for future use. Saving a document is similar to saving other application files. Content from all sections is saved. The following saving options are available:

· Save the results of your query with the document.

· Save the document in a compressed format. This results in smaller file sizes, which saves valuable storage space and enables the document to be quickly transmitted. The decompression of the compressed file happens automatically when the document is reopened. Brio clients can be configured to save all documents in compression file format by globally enabling the Compress All Documents Option.

· Password protect a document. Users must enter a password to open the document.

To save a new document:

1. On the File menu, click Save As.

2. In the Save File dialog box, select a directory, enter the name of the file, choose a file type, and then click Save.

To save the document in a compressed format:

· On the File menu, point to Save Options, and then click Compress Document. A check mark is displayed next to the Compress Document feature.

To configure all documents to save in compression file format:

1. On the Tools menu, point to Options, and then click Program Options.

2. In the General tab, choose Compress all documents and/or Create new documents compressed.

To save the results with a document:

1. On the File menu, point to Save Options, and then click Save Results With Document.

2. In the Save Results With Document dialog box, click the check boxes for the queries for which you wish to save results, and then click OK.

To password protect a document:

1. On the File menu, point to Save Options, and then click Password Protect Document.

2. In the Password Protect Document dialog box, enter a password, and then click OK.

Printing Reports XE "Printing Reports" 
Users can print an active document section using the Print command.

To print a section:

1. In the Section pane, select the section to print.

2. On the File menu, click Print.

3. Configure the print dialog box, and then click Print.
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Exporting Report Sections XE "Exporting Report Sections" 
Report sections can be exported as common file formats such as Excel or Lotus. Sections can also be exported as HTML format, making it easy to distribute data to many corporate intranets or Web sites.

To export a report as a common file format:

1. On the File menu, point to Export, and then click Section.

2. Configure the Export Section dialog box, and then click Save.

· Select a destination directory for the export file.

· Type a name for the section to be exported.

· Choose a file format from the Save as Type menu, and then click Save. The table below describes common extensions for format types.

· Acrobat (*.pdf)

· HTML (*.htm)

· Excel (*.xls)

· Lotus 1-2-3 WKS (*.wks)

· Tab-delimited text (*.txt)

· Comma-delimited text (*.csv)

· JPEG (*.jpg)
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Copying to the Clipboard XE "Copying to the Clipboard" 
Use the clipboard to cut and paste data into other applications. If you are operating in a Windows environment, you can use DDE/Pastelink with the clipboard. If you are operating in a Macintosh environment, you can use Publish/Subscribe to export the Results set to an edition file.

NOTE Copying to the clipboard is not available for documents assigned with the “View” privilege.

To export using DDE/Paste Link (Windows only):

1. Select the data to be exported in the Contents pane.

2. On the Edit menu, click Copy to copy the data to the clipboard. Data is copied to the clipboard as tab-delimited text, one row per line.

3. In the target application, on the Edit menu, click Paste to insert the data from the clipboard, or activate Paste Link to transfer the data from the clipboard.

Lesson 4 Summary

In this lesson you have learned:

· Users are provided a URL by an administrator to a Web page where they can log on to the OnDemand Server and access a list of documents. Documents can also be stored on a file server, where users can access them without logging into the OnDemand Server.  Functionality, however, is reduced.

· Each user is assigned to a group, which is assigned a one of the following document privileges: “View”, “View and Process”, “Analyze”, “Analyze and Process” or “Query and Analyze”. When a document is accessed, a user will be able to perform only those tasks permitted by the document privilege. Keep in mind, documents can be set with a privilege that overrides a user’s default.

· Brio.Insight users cannot modify locked Data Models.

· There are three processing options: Process Current (Process), Process All, and Process Custom. Documents can be configured by an administrator to process automatically when they are opened. Documents can also contain variable limits, which require users to enter limit values before the processing is completed.

· Opening documents within a browser, without connecting to an OnDemand Server, provides Brio.Quickview users with “View” capabilities and Brio.Insight users, “Analyze” capabilities.

· Documents that have been saved locally or to a file server that originate from the OnDemand Server can be reconnected by performing an action that requires database connectivity. For example, processing queries.

· To save a document, on the File menu, click Save As. Browse to a directory, enter a file name, choose a file format, and then click Save.  There are three saving options: Save Results With Document, Compress Document, and Password Protect Document. To select an option, on the File menu, point to Save Options, and then click an option.

· Any document section can be printed.

· Reports can be exported as different file formats for use in other applications. File formats include HTML (*.htm), Excel (*.xls), Lotus 1-2-3 WKS (*.wks), Tab-delimited text (*.txt), and Comma-delimited text (*.csv)

· Copy report data to the clipboard to paste into other applications. This is not available for documents with the “View” privilege.
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Chapter 2   Creating Queries XE "Query section"  from Pre-built Data Models

This unit focuses on building queries utilizing pre-built data models. Users are introduced to the basic concepts of data modeling and begin to create simple queries.

Upon completion of this unit users will be able to:

· Identify the following key terms:

· Query

· Data Model and Master Data Model

· Topic and Item

· Join

· Structure View, Detail View, and Icon View

· Data Function

· Join Path

· Variable Limit

· Understand the query and report building process

· Understand the structure of data models

· Access pre-built data models in the document list

· Investigate the underlying data

· Create simple queries using the Request line

· Define limits on the database server

· Create variable limits

· Define sort conditions on the database server

· Process and cancel queries

· Create multiple queries in a document

· Process multiple queries simultaneously

· Aggregate a query by applying various data functions

· Set a limit on an aggregated Request item

· Import data files

· Select join paths, when necessary

· Change topics into Icon View, when necessary

Lesson 1: Query Fundamentals

Lesson Objectives

Upon completion of this unit users will be able to:

· Identify the following key terms:

· Query

· Data Model

· Master Data Model

· Topic

· Item

· Join

· Structure View

· Detail View

· Variable Limit

· Understand the query and report building process

· Understand the structure of data models

· Access pre-built data models in the Repository

· Access pre-built data models in the document list

· Investigate the underlying data

· Create simple queries using the Request line

· Define limits on the database server

· Create variable limits

· Define sort conditions on the database server

· Process and cancel queries

· Create multiple queries in a document

· Process multiple queries simultaneously

Query Building XE "Query" 
A query is set of database instructions to return an answer set to a specific question. Each row returned in the result set is an answer to the question.  There may be a few rows returned or many, depending on the question.  Data warehouses are built specifically to make querying fast and easy.  There are many easy techniques to help users build queries, such as drag-and-drop, double-click, right-mouse click, and toolbar selection.

Pre-Built Data Models XE "Data Models, pre-built" 
Administrators can provide users with documents containing pre-built data

models for users to simplify the query building process. Data models are

represented in the Query section of a document.

A Data model is a representation of a portion of an actual database. In a document, it is represented by one or more topics in the content pane of the Query section. In business terms, a data model represents a particular business activity. For example, a sales data model may represent sales orders by customers for particular products over a period of time.

A Data model consists of topics and items. Topics usually represent actual database tables, but can represent customized views of tables as well.  Items are listed in topics and usually represent actual database columns.

If several topics are part of data model, users may/may not see joins XE "Joins"  (lines) between the topics XE "topics" . Administrators can choose to hide or display these.  Often they are hidden to keep the data model simple looking. The purpose of the joins is to establish the relationships between the database tables.  In turn, users are able to request information from more than one table at a time. Creating data models requires a good understanding of the underlying data and database design.
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Topics in a data model are not always exact representations of actual database tables. Data models are built to hide the complexity behind the data to make query building easy. For example, several database tables can be represented as one topic and can consist of pre-calculated items.  This lets the business users focus on the business questions, rather than the database design.

There may also be certain restrictions placed on a data model, such as a limit to the number of rows a query can return. In any case, it is important to become familiar with what part of the business a data model represents and what has been built into it to make querying easier. The better users understand the data model, the better they will understand the results of their queries.

Master Data Models XE "Data Models:master data model" 
A document can contain a master data model, which enables users to base multiple queries on the same data model within a document. When using a master data model, the text “Locked Data Model” appears in the content pane of the Query section. This means that the data model is linked to the data model displayed in the DataModel section (which may be hidden by an administrator). Changes cannot be made to master data models from within the Query section (with the exception of Icon View).
Accessing a Data Model XE "Data Models:accessing a data model" 
To access a data model on the web:

1. Access the document list on the web, browse the folders in the tree control, and then select a document that contains a data model.

2. Click Query in the Section pane to move to the Query section.

Investigating the Underlying Data XE "Data Models:investigating the underlying data" 
The data model is displayed in the Query section of a document. Topics are displayed in Structure View, by default, which displays the topic’s name and items. Features such as Detail View and Show Remarks are useful for learning more about the underlying data behind the data model.  They help users to learn about the topics and items needed for their queries.

Detail View

To view actual rows in a database table, convert a topic in a data model to Detail View XE "Detail View" . The default is to display 10 rows of data; however, an administrator can set this number. Situations where Detail View will not be available are:

· if the topic contains computed columns

· an administrator has disabled Detail View for a topic

To change a topic into Detail view:

· Right-click a topic’s title bar, and then click Detail View. To return to the original view (which is referred to as Structure view), right-click a topic’s title bar, and then click Structure View XE "Structure View" .

Showing Database Remarks XE "Query section:displaying database remarks" 
Database remarks functions similarly to context-sensitive help by displaying information about selected topics or items, and can be very helpful when creating queries. Remarks often include descriptive text, date last updated, and information about where the data originated. If an administrator has not configured the connection file to look up remarks, then you will not be able to do this.

To display a remark for a topic or item:

· Right-click a topic’s title bar or an item, and then click Show Remarks.

Building the Request Line XE "Data Models:building the request line" 
By adding items to the Request line in the Query section, the database is instructed to return data for those particular items XE "Data Models:items" . Some items may represent actual columns in the database and some may require database calculations. To the user, it is transparent. The Request line is expandable and can wrap text to display multiple rows of request items.

To add an item to the Request line XE "Query section:add items to the Request line" :

· Drag a topic item to the Request line. Alternatively, right-click a topic item, and then click Add Selected Items.
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· Multiple topic items can be added at the same time by making a contiguous or discontiguous selection, right clicking, and then clicking Add Selected Items.

· Items from different topics cannot be added at the same time.

To remove Request items XE "Query section:removing Request items" :

· Drag items off of the Request line to remove them from a query.

To remove all of the Request items in one step XE "Query section:removing all Request items" :

· Right-click Request on the Request line, and then click Remove.

To reorder Request items XE "Query section:reordering Request items" :

· Drag items on the Request line to new positions.

Limiting a Query

Most queries require that a limit be set on the data to be retrieved.  Database tables usually contain large amounts of data and users want to avoid requesting unnecessary information. Before processing a query, make sure that all of the appropriate limits are set in the Query section.

In the Query section, users can:

· query a database for possible limit values

· manually specify limit values

· create custom lists of limit values

· obtain limit values from a text file

· define compound limit formulas on the Limit line

· set limits as variable to prompt the user to select values

Setting a Limit XE "Query section:setting a limit" : General Steps

To set a limit in a query:

1. Click Limit on the Section Title bar in the Query section to display the Limit line.

2. Drag a topic item to the Limit line. The Limit dialog box appears.
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3. Configure the Limit dialog box, and then click the OK button. The limit is set and the item is added to the Limit line.

· Choose a logical operator from the pull-down list.

· Enter values (separated by commas) in the Edit field.

· Select one or more values depending on the comparison operator.  For example, when using "=," select as many values as needed.  When using "between," select two values. When using ">=", however, select only one value.
Field Definitions XE "Limit Dialog Box:Field Definitions" 
Available fields and options for the Limit dialog box are:

	Option
	Function

	Ignore
	Suspends a limit temporarily without deleting it.

	Include Null
	Toggles the inclusion/exclusion of null values.

	Operator
	Choose a logical operator for use in a limit equation.



	Not
	Reverses the effect of an operator (for example,

Not >= is equivalent to <).

	Edit
	Enter a value (or multiple values separated by

commas), and click the green check mark button

to add them to the custom values list to complete

the limit definition.

Click the red x button to erase the contents of the

Edit field.

	Show Values and Transfer
	Transfer Retrieves all potential values associated with the item from the database. This allows users to consider and select from the actual range of

values when applying a limit. Transfer adds

selected values to the custom list. Show Values

cannot be used in the Query section for limits on

computed, aggregate, or computed meta topic

items.

	Custom Values XE "Limits:Custom Values list" 
	Displays a list of potential values saved with the

limit or read from a file. This feature enables users

to select values from a pre-defined pool. Users

can create and save a custom list with each limit.

	Custom SQL
	Displays the Custom SQL dialog box for coding

limits directly in SQL.

	Select All
	Selects all values displayed in the values panel.

	Remove
	Removes selected values from a custom list or a

limit.


Entering Limit Values XE "Limits:Entering Limit Values" 
Limit values can be manually entered in the Limit dialog box. This essentially creates a list of Custom Values. Enter values as opposed to using the Show Values button for items that rarely change.

Modifying Limits XE "Limits:Modifying Limits" 
Limits can always be modified by double-clicking them on the Limit line and reconfiguring the Limit dialog box. Beware in the case of the Show Values mechanism. When a Limit item is reopened and Show Values was last selected, the database is automatically re-queried to refresh the values list.  This can add time when modifying limits. If limit values are entered into the Limit dialog box, then the next time the limit is altered, the limit values are instantly presented because they are stored locally with the document. An advantage to entering limit values in the Limit dialog box is that it reduces the time required to alter limits because the values are stored with the document.

Complex Limits XE "Limits:Complex Limits" 
Use the Limit line in the Query section to apply more than one limit to a single item, or create complex conditions dependent on more than one constraint. The Limit line provides AND and OR Boolean operators as well as parentheses, which are used to control the order of operations on the Limit line. The second instance of an item on the Limit line displays a “2” next to the item name, and so on.

NOTE The OR operator and parentheses are not available in the Results section.

The following rules of syntax apply to all Limit line expressions. When creating a complex limit, be sure to verify that the expression is delivering the correct results.

· The AND XE "Limits:AND"  operator retrieves data that meets both conditions. To retrieve data which satisfies either of two conditions, use the OR XE "Limits:OR"  operator.

· By default, equations are solved from left to right, with enclosed sub-operations evaluated first. AND is evaluated before OR.

· Sub-operations override the default evaluation order, and may be required for certain operations involving both AND and OR operators.

To create complex Limit line expressions:

1. Drag two or more topic items to the Limit line and apply individual limits using the Limit dialog box. An AND operator appears between each item on the Limit line.

2. Click the small arrow at the left edge of the Limit line. The Limit line is adjusted to display the Limit line control buttons.

3. Select from the limit controls to complete the equation:

· Switch Boolean operators AND and OR by clicking the operator.

· Enclose sub-operations by selecting items to be enclosed and clicking the parentheses XE "Limits:Parentheses ()"  () button. To remove parentheses, right-click, and then click Remove.
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Variable Limits XE "Limits:Variable Limits" 
A variable limit XE "Query section:variable limits"  is a preset limit that is resolved when a query is processed.  At that time, a user is prompted to select or enter limit values to complete the constraint. Using variable limits eliminates the need for multiple queries using different limit values. This enables administrators to deploy one query, versus several.

Variable limits work particularly well with Custom Values lists. If a Custom Values list is created, a user can respond to the prompt by simply selecting a value from the list. Each time a document is processed, limit values are selected rather than manually redefined each time.

To establish a variable limit:

1. Display the Limit line in the Query section.

2. Click the small arrow at the left edge of the Limit line to display the extension.

3. Select a Limit item, and then click the Var button on the Limit line extension.

· The Limit item is displayed with a V(1) beside it, indicating a variable limit.

· If other limit items are variable, they are displayed with V(2), V(3), etc. to indicate the order in which the user is prompted to respond to the Variable Limit dialog box when the query is processed.
Instructing the Database to Sort XE "Query section:sorting"  the Data

Use the Sort line in the Query section to instruct the database to sort the data before it is returned. It is possible to define nested sort conditions. The database sorts items on the Sort line from left to right. Only items on the Request line can be included on the Sort line.

To instruct the database to sort Request items:

1. Click Sort on the Section Title bar to view the Sort line.

2. Drag the items to sort from the Request line to the Sort line.  Alternatively, select Request items, and then click one of the sort icons on the Standard toolbar.
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3. Double-click a Sort item to toggle ascending and descending sort orders. Alternatively, select a Sort item, and then click the Sort Ascending or Sort Descending icon on the Standard toolbar.

4. When the query is processed, the database sorts the data and then returns it.

Estimating Query Sizes

Use the Estimate Query Size feature to query the database for the number of records a query will retrieve. Use this feature to test questionable queries and postpone processing huge results sets during peak network periods.

To estimate the size of a query XE "Query:estimating the size of a query" :

· On the Query menu, click Estimate Query Size. Variable limits need to be resolved before the Query Count dialog box displays the results. 
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NOTE Query Size is not available when the Custom SQL window is in use.

Query Properties XE "Query:query properties" 
When working with very large or unfamiliar databases, occasionally a query takes a long time to process or it returns more data than is manageable. To prevent problems under these conditions, set a temporary constraint on the query by modifying the query properties.

NOTE A distributed data model may include query restrictions set by an administrator. If additional query restrictions are set by the user, the more restrictive setting takes precedence.

To modify query properties:

1. On the Query menu, click Query Options. A Query Properties dialog box appears.
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2. Set the desired restrictions for the current query, and then click the OK button.

Field Definitions XE "Query Properties Dialog Box:available fields and options" 
Available fields and options for this dialog box are:

	Fields and Options
	Definition

	Return Unique Rows
	Select the check box to eliminate duplicate rows from

the data set retrieved by the query.

	Return First ___ Rows
	Select the check box and enter a value in the adjacent field to limit the number of database rows retrieved.

	Time Limit ___ Minutes
	Select the check box and enter a value in minutes to

limit the time the query is allowed to run. Seconds are entered as a decimal number. Time limits work for asynchronous database connections, and cancel at the earliest opportunity for non-asynchronous connections.

	Custom Group By
	Select the check box to customize the Group By criteria used to compute aggregate Request items, with selected items not factored into the grouping.  This feature is available only when a data function is

placed on a Request item. (Red Brick Warehouse

database only)


Processing Queries

Since multiple queries can exist in a document, there are three processing options on the Standard toolbar: Process Current, Process All, and Process Custom.

· Process Current XE "Processing Queries:Process Current"  processes the query that is currently active.

· Process All XE "Processing Queries:Process All"  processes every query in the document. If a query is not connected to a database, users are prompted to logon.

· Process Custom XE "Processing Queries:Process Custom"  opens a Process Custom dialog box and enables users to choose specific queries to process.

Once a query is created, it is ready to be processed by the database.  Processing requires a database connection. Queries may process quickly or take a while, depending on what the database is requested to do, the number of users running queries on the database, and how busy the network traffic is at that moment.

When the data is retrieved, the Results section displays it in tabular form.  If the Results set was not what was needed, the query can be modified and reprocessed at any time.

NOTE An administrator can disable the Process button (via a setting in the connection file) if topics in a data model are not properly joined.  This may happen if users remove a topic in a data model and it is needed to join two other topics together.

To process a query XE "Processing Queries:processing a query" :

· Click the Process button on the Standard toolbar. During retrieval, the Status bar displays a dynamic row count indicating the rate and progress of database processing and network transfer.

To cancel a query:

· Simultaneously press and hold the [Alt] and [End] keys on the keyboard until the query is cancelled.

Multiple Queries per Document XE "Processing Queries:multiple queries per document" 
Documents can contain multiple queries; that is, multiple Query sections.

To process multiple queries:

· Select Process All or Process Custom on the Standard toolbar.

· If Process Custom is selected, a Process Custom dialog box appears. Click the check boxes beside particular queries, and then click the OK button.

Lesson 1 Summary

In this lesson you have learned:

· Data models are used as the starting point for creating queries. A query is a set of database instructions to answer a specific question about the business. Queries are built in the Query section of a document.

· A data model represents a subset of a database. It consists of topics and items. Topics represent tables in the database (or customized views of tables) and items represent columns in the database or pre-defined calculations.

· A data model can consist of one topic or many. If there are many topics, the joins between them may or may not be visible depending on how your administrator creates it.

· Documents can contain master data models, which enable users to create multiple queries with the same data model.
· Another way to learn more about the data is to use the Show Remarks feature. To view a remark for a item, right-click a item, and then click Show Remarks. Administrators who utilize this feature often include item descriptions in the database as well as update and source information. 

· When creating any query, topic items need to be added to the Request line. Selection will depend on the type of information needed. To populate the Request line, drag topic items to the Request line or right-click a topic item and then click Add Selected Items.

· Make sure to set limits on queries to prevent requesting too much data from the database. A limit can always be modified and the query reprocessed if the results set was not what was needed.

· Use the Show Values button in a Limit dialog box to query a database for unique limit values. Exercise caution when doing this, especially if there is the potential for a large number of possible values.

· Manually enter limit values to avoid querying a database.

· Custom Values lists can be created manually or automatically by transferring values obtained from a database or text file. 

· AND and OR Boolean operators and parentheses are available on the Limit line in the Query section to provide limit logic. Double-click an operator to toggle it from AND to OR.

· Variable limits prompt users to enter limit values at process time. This adds flexibility to queries and minimizes query duplication. To make a limit variable, select a Limit item, and then click Var on the Limit line extension.

· To instruct the database to sort the data before it is returned, drag Request items to the Sort line in the Query section. Double-click Sort items to toggle ascending and descending sort orders.

· To send a query to a database, click the Process button on the Standard toolbar. Allow for some time to pass while the query is being processed. To cancel a query, simultaneously press and hold the [Alt] and [End] keys on your keyboard until the query is cancelled. (For Macintosh, press [Command]+[.(period)]).

· There are three processing options on the Standard toolbar, which include Process Current, Process All, and Process Custom. 
· To find out the number of rows a query is going to return before it is processed, on the Query menu, click Estimate Query Size. If a query contains variable limits, these need to be resolved before a row count is determined.

· Queries can be restricted to return unique rows only, return a finite number of rows, or process for a specific time period. To use these settings, on the Query menu, click Query Options.
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NOTES:
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Practice Exercise: Query Sections (Leave Report)

Objective

Create several queries from one master data model that retrieve leave data for your organization.  Include annual, sick, credit and comp time hours for your employees.  Practice applying limits and sorts to your data.

BrioQuery Features

This exercise provides practice on the following query building techniques:

· Building a Request line

· Setting limits

· Sorting a query

· Processing a query

· Creating multiple queries

Steps

· To get started, access the Client Leave Annl, Sick & Lwop document from the Client Orientation folder.

	


	Report Catalog
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 HYPERLINK "javascript:top.openBranch(%22Client%20Orientation%22)" 

	Client Orientation
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 HYPERLINK "javascript:top.openBranch(%22Client%20Combined%20File%20Rpts%22)" 

	Client Combined File Rpts
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 HYPERLINK "javascript:top.openBranch(%22Client%20Ad%20Hoc%22)" 

	Client Ad Hoc
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	Client EEO
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 HYPERLINK "javascript:top.openBranch(%22Client%20Leave%22)" 

	Client Leave
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	 Client Leave Annl,Sick & Lwop 


· Change the variable limits to locked limits

· Focus on the Query section

· Right-click the “Dept V(1)” limit

· De-select “variable”

· Double-click the “Dept” limit

· Enter “NN” in the limit dialog

· Click the green check mark

· Click “OK”

· Repeat  for “Bureau” using your center code number (i.e. HQ=10)

· Repeat for “Sub Bur” using “00” (zero-zero)

· Place a sort on the Leave Annual Curr Bal item to sort in descending order.

· Process your query.

· “Ignore” the “Org V(4)” limit by pressing the “Ignore” button.

· Review your results.

· Double-click Results on the section catalog and change the name to Leave Results.

· Left-click the Query section to focus the application; then right-click and choose “Duplicate Section” from the hot menu.

· Clear the Request line

· Right-click the “Request” label at the beginning of the line and choose “Remove”

· At your new query section, add the following items to the Request line:  Dept, Bureau, Subbureau, Org, Name Whole, and Leave Comp Avail Occ Total
· Double click on Employee Status History Type and apply a limit where the value is equal to A, C, F, I, L, and M for active records in UPPER CASE letters.

· Double click on the Leave Comp Avail Occ Total item to apply a limit to retrieve values greater than 0.

· Process your query.

· Review your results.

· Double-click the second Results and change the name to Comp Time Results.

· From the “Insert” menu, choose “New Pivot”

· Drag “Org” from the section catalog and drop it in “Side Labels”

· Drag Leave Comp Avail Occ Total to “Facts”

· Save your new document to the desktop.
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Lesson 2: Aggregating Queries

Lesson Objectives

Upon completion of this lesson users will be able to:

· Identify the following key terms:

· Data Function

· Aggregate a query by applying various data functions, including:

· Sum

· Average

· Minimum and Maximum

· Count and Count Distinct

· Set a limit on an aggregated Request item

Data Functions XE "Data Functions" 
A data function can be applied to a Request item in the Query section to compute aggregate values on the server, such as averages, sums, counts, maximums, and other statistics. Aggregating the data creates summarized groups and reduces the result set to a smaller number of rows.

Below lists common data functions available in the Query section XE "Query section:common data functions" .

	Data Function
	Meaning

	None
	Returns unaggregated values as stored in the database.

This is the default in Query.

	Sum(c) XE "Data Functions:Sum(c)" 
	Returns the sum of all values in c.

Example: sum(units)=sum of all values of units.

	Average(c) XE "Data Functions:Average(c)" 
	Returns the average of all values in c.

Example: avg(units)=average of all values of units

	Minimum(c) XE "Data Functions:Minimum(c)" 
	Returns the minimum value of all values in c.

Example: min(amount)=smallest dollar amount

	Maximum(c) XE "Data Functions:Maximum(c)" 
	Returns the maximum value of all values in c.

Example: max(units)=largest order size


	Count(c) XE "Data Functions:Count(c)" 
	Returns the number of row values in c, including nulls and

duplicates.

Example: count(order_number)=number of orders, including

duplicate orders and null entries

	Count Distinct(c) XE "Data Functions:Count Distinct(c)" 
	Returns the number of unique row values in c.

Example: count(distinct(order_number))=a count of unique

order numbers, including a count of 1 for all null order

numbers; duplicate order numbers are counted once

	Weight(c) XE "Data Functions:Weight(c)" 
	The statistical calculation for weighted averages depends

on the mathematical formula (c * w) / sum (w) where c is a

data item for which weight values are needed and w is the

data item containing the weighted values.

The weighted values are returned in the Results section;

however, the weighting functions work in the Pivot report

only.


Applying a Data Function XE "Query section:applying a data function" 
To apply a data function to a Request item in the Query section:

· Right-click a Request item, point to Data Functions, and then click a data function.

Limiting Aggregate Items XE "Query section:applying limit to aggregated item" 
Limits can be applied to aggregated Request items by dragging them to the Limit line. However, Boolean logic (AND and OR XE "Limits:AND and OR Boolean operators" ) and variable limits are not available.

To apply a limit to an aggregated item in the Query section:

1. Drag an aggregated Request item to the Limit line.

2. Configure the Limit dialog box, and then click the OK button.  Notice that a line appears on the Limit line separating the limits applied to non-aggregated items and aggregated items.

Lesson 2 Summary

In this lesson you have learned:

· Data functions can be applied to Request items to summarize queries.  Common functions include sum, average, and count. When a data function is used, the query is referred to as aggregated. Aggregating queries reduces the number of rows returned from the database and presents the data in the Results section at a summary level. To apply a data function to a Request item in the Query section, select a Request item, right-click, point to Data Functions, and then click a data function.

· A Limit can be set on an aggregated Request item by dragging the item from the Request line to the Limit line. Once configured, the Limit item is displayed to the right of the Limit line to indicate the item is aggregated. In more technical terms, the Limit item is part of the “having” clause in the SQL statement. Non-aggregated limit items are displayed on the left side of the Limit line.
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Practice Exercise: Charity Amount/Sum/Max/Min

Objective

Create a query that includes the Org Code and Amount Charity items.  Apply a data function to the Amount Charity item on the Request line in the Query section to compute the sum of aggregate values as well as the maximum and minimum values.

BrioQuery Features

This exercise provides practice on the following techniques:

· Applying a data function

· Applying a limit to aggregate items.

Steps

· To get started, access the document named Ad Hoc (4) in the document list.

· Remove all request items after “Org Desc”

· HINT: shift left-click to select multiple items.

· Add Amount Charity & Salary Or Pay Rate to the Request line.
· Apply the Sum data function to Amount Charity, Average to Salary Or Pay Rate.

· Rename the aggregated items as Total Charity, Average Salary respectively.

· Limit the Average Salary field to salaries greater than 50000
· To prevent a “run-away” query, set a time limit on this query by double-clicking Request on the Request line and setting the time to 2.00 minutes.

· Process the query.

· Save the document to your desktop as DataFunc.

 Lesson 3: Importing Data Files XE "Importing Data Files" 
Upon completion of this lesson users will be able to:

· Import data files in the following formats

· Microsoft Excel (*.xls)

· comma delimited (*.csv)

· tab delimited (*.txt)

Files containing data XE "Importing Data Files:data files" 
An alternate method of querying is to import data from a file. File formats include:

· Microsoft Excel (*.xls)

· comma delimited text (*.csv)

· tab delimited text (*.txt)

When data is imported, a new Table section is created in the current document. The data can then be manipulated in the same manner as a Results set of a query.

To import a data file:

1. On the File menu, point to Import Data File, and then click Data File.

2. Browse to the location of the import file, select the import file, and then click the OK button. The data from the import file is displayed in a Table section with the first row as column titles.

Files containing SQL XE "Importing Data Files:SQL files" 
1. An alternate method of querying is to import SQL text. This step replaces the query building process. Once the SQL is imported it simply needs to be processed to retrieve results. Users can leverage SQL text that has already been scripted, minimizing query creation and building efforts.

Lesson 3 Summary

In this lesson you have learned:

· Excel and text files (tab and comma delimited) can be immediately imported into a Table section. A database connection is not required.  To do this, on the File menu, point to Import Data File, and then click Data File. Browse and select an import file, and then click the Open button. The data in the import file is imported into a Table section with the first row of data as the column headings.

· Queries can be processed based on imported SQL text.

Chapter 3 Results and Table Sections

Upon completion of this unit users will be able to:

· Identify the following key terms:

· Results section

· Local limits

· Table Section

· Understand the purpose of the Results section

· Create simple reports in the Table section

· Apply local limits in the Results and Table sections

· Sort tables

· Apply totals and break totals to tables

· Format tables
Lesson 1: Working in the Results Section XE "Results section" 
Lesson Objectives

Upon completion of this lesson users will be able to:

· Identify the following key terms:

· Results section

· Local limits

· Understand the purpose of the Results section

· Apply local limits in the Results section

About the Results Section

The Results section acts as a place to massage or prepare the data for pivot, charts, tables, and free-form reports. It is also used to verify the accuracy of a query. Although a query may have accessed several different database tables, the data is consolidated into a single table in the Results section. Each requested item is arrayed in a column field, and there is a row for each database record. In order to be able to create reports, data must be available in the Results section. If the results of a query were not saved with a document, then creating reports and analyzing data is not possible.

Below is an example of a Results section.
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Massaging the Dataset

Pivot, chart, and table reports are based on the results set of a single query, whereas free-form reports can reflect data from several queries.  Results data can be prepared by applying local limits and formatting numbers.

Local Limits XE "Limits:Local Limits" 
Applying limits in the Results section enables a user to “locally” filter the dataset returned from a query. These types of limits are referred to as local limits. Since report sections are based on Results data, local limits also filter data in the report sections. Because local limits only hide data from the display, they are a good way to filter the dataset to reflect temporary and hypothetical situations. A limit can always be suspended or deleted to return data to the display and make it available for reporting. The Status bar displays the total number of rows in the dataset, after local limits have been applied. Columns can have one limit applied only.

To apply a local limit XE "Results section:applying a local limit" :

1. Double-click a column in a Results section. A Limit dialog box appears.

2. Configure the Limit dialog box.

· Choose a logical operator from the pull-down list (if they are listed).

· Create a Custom Values list by supplying a value (or values, separated by commas) in the Edit field, and clicking the green check mark button. 

                                
[image: image49]
3. When the values are highlighted in the values panel, click the OK button. The limit is applied to the column and the column name is added to the Limit line.

To remove a limit XE "Limits:Removing a Limit"  in a results set:

· Right-click a Limit item, and then click Remove.

To remove all limits XE "Limits:Removing all Limits"  in a results set:

· Right-click Limit on the Limit line, and then click Remove.

Formatting Numbers in Results XE "Formatting Numbers in Results"  XE "Results section:formatting numbers" 
Format numbers once in the Results section to avoid formatting them each time they are used in a report section.

To apply a number format to a column XE "Results section:applying a number format" :

1. Select a column, right-click, and then click Number. A Properties dialog box appears.

2.  In the Numbers tab select a number format, and then click the OK button.


Lesson 1 Summary

In this lesson you learned:

· The Results section stores the dataset returned from a query. Data is prepared and refined for reports.

· In order to create reports, data must be available in the Results section.  If data is missing, it means that the data was not saved with document and the query needs to be reprocessed.

· Apply local limits to refine data in the Results section. Double-click a column and enter the limit constraint in the dialog box. A column can only have one limit applied to it. The Status bar displays the remaining number of rows in the dataset after limits are applied.


NOTES:


Practice Exercise: Results Section

Objective

Open the query Leave.bqy from within your browser.  Create a query that includes the Org Code and Amount Charity items.  Apply a data function to the Amount Charity field on the Request line in the Query section to compute the sum of aggregate values as well as the maximum and minimum values.

BrioQuery Features

This exercise provides practice on the following techniques:

· Applying a data function

· Applying a limit to aggregate items.

Steps

· Open the query Leave.bqy saved in a previous exercise by clicking on File from the web browser Main Menu and select Open/Open Page.

· Browse/Choose File that you wish to open and click OK/Open.

· Add Date of Birth to the query containing Annual/Sick Leave data.

· Process the query.

· Log into the OnDemand Server.

· Enter limitations for your Organization’s values.

· In the Results Section place a limitation to the Leave Sick Curr Bal field to retrieve only those whose Sick Leave balance is greater than 300

· Change the font size of the entire Results Section to Arial 10.

· Resize the columns to fit the data.

· Sort the results to display the Leave Sick Curr Bal field in ascending order.

· Format both Leave columns as #,##0.00

· Format the Date of Birth column as mm/dd/yy

· Resave the query as Leave.bqy.


NOTES:


Lesson 2: Creating Tabular-Style Reports XE "Table section" 
Lesson Objectives

Upon completion of this lesson users will be able to:

· Identify the following key terms:

· Table Section

· Create simple reports in the Table section

· Apply local limits in the Table section

· Sort tables

· Apply totals and break totals to tables

· Format tables

About Tabular-Style Reports

The Table section is used for creating tabular-style reports. The data is not summarized in the Table section, as it is in the other report sections. The data is presented at the same granularity level as in the Results section.

Table sections share the same functionality as Results sections. Pivots, Charts, and free-form reports can be created based on a table’s dataset, in the same way reports are derived from a Results dataset.

The Outliner in the Table Section contains Request items that are to be included in the table report. Below is an example of a blank Table section.

          
[image: image50]
To create a table report XE "Table section:creating a table report" :

1. On the Insert menu, click New Table.

2. Drag Request items from the Catalog into the Outliner. Click the Outliner button on the Section Title bar if it is not displayed below the content area. A Request item can be added only once to a table.

Removing and Hiding Columns

Columns can be removed from or hidden in a table report. If a column is not added to the Outliner or it is removed from the Outliner, then it cannot be displayed in reports or referenced in local computed columns. If a column is added to the Outliner, and then hidden, it is not displayed in the table report, but can be referenced in local computed columns and displayed in other reports.

To remove a column XE "Table section:removing a column"  in a table report:

· Select a column in a table, right-click, and then click Remove Column.

To hide a column XE "Table section:hiding a column"  in a table report:

· Select a column in a table, right-click, and then click Hide Column.

Sorting Tables XE "Table section:sorting" 
The rows in a table report can be sorted based on a single column or multiple columns. Use the Sort buttons on the Standard toolbar to quickly sort a column or multiple columns in the same order (ascending or descending). Use the Sort Line to view Sort items and to apply nested sorts to multiple columns using combinations of ascending and descending sort orders.

To sort a column using the Sort buttons XE "using the Sort buttons" 

 XE "sorting:using the Sort buttons" :

· Select a column to be sorted, right-click and select Sort Ascending or Sort Descending.

To apply sort conditions using the Sort line XE "using the Sort line" 

 XE "sorting:using the Sort line" :

1. Click Sort on the Section Title bar to display the Sort line.

2. Drag Request items from the Catalog pane to the Sort line.

· Establish a final sort sequence by reordering Sort items. Items are sorted from left to right.

· Double-click specific Sort items to toggle ascending and descending sort orders. Ascending is the default sort order.

3.  Click Sort on the Sort line to begin sorting.
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Local Limits XE "Limits:Local Limits" 
Set limits on columns in a table report to filter the data displayed. Table section limits are in addition to the limits set in the Results section. Keep in mind that limits applied in a Table section are also applied to other reports that stem from a Table section. Limits can be suspended or deleted to return data to the display and make it available for reporting. The Status bar displays the total number of rows in the table report, with limits applied.  Only one limit per column can be applied.

To limit data XE "Table section:limiting data"  in a table report:

1. Double-click a column in a table report. A Limit dialog box appears.

2. Configure the limit dialog box:

· Create a Custom Values list by supplying a value (or values, separated by commas) in the Edit field, and then clicking the green check mark button.

· Enter values (separated by commas) in the Edit field.

· Select one or more values depending on the comparison operator.  For example, when using "=," select as many values as needed.  When using "between," select two values. When using ">=", however, select only one value.
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3. When the values are highlighted in the values panel, click the OK button. The limit is applied to the column and the column name is added to the Limit line.

To remove a limit in a table report:

· Right-click a Limit item, and then click Remove.

To remove all limits in a table report:

· Right-click Limit on the Limit line, and then click Remove.

Grand Totals and Break Totals XE "Results section:break totals" 
Table reports can display grand totals and break totals. Multiple grand totals can be displayed at the bottom of a column, each with a different data function applied. Break totals are defined in reference to data in other columns, which define a break point for the total. Data functions for break totals can also be defined.

Break totals are generated using break columns. The break column contains the data by which to group (break) the totals. The break column usually contains text values.

Grand Totals

To generate a grand total XE "Table section: generating a grand total"  on a column:

1. Select any column in a table.

2. Right-click, and then click Grand Total.

3. Configure the Insert Grand Total dialog box:

· Select a data function from the first pull-down menu

· Select a column from the second pull-down menu
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4. Once the Insert Grand Total dialog box is configured, click the OK button. A total is displayed at the bottom of the selected column.

TIP To quickly create a grand total using the sum data function, select a column, and then click the Grand Total button on the Standard toolbar.

To remove a grand total XE "Table section:removing a grand total"  in a table report:

1. Highlight a grand total row by clicking in the left margin. The grand total row is highlighted.

2. Right-click, and then click Remove Row. The grand total is removed.

To remove all grand XE "Table section:removing all grand totals"  totals in a table report:

1. Select any column in a table report, right-click, and then click Grand Total.

2. In the Insert Grand Total dialog box, click the Remove All button, and then click the OK button. All grand totals are removed in the table report.

To change the data function XE "Results section:changing the data function"  applied to a grand total:

1. Double-click a grand total in a table report.

2. In the Modify Total Function dialog box, select a data function from the pull-down menu, and then click the OK button.

To create a label for the grand total row XE "Table section: creating a label for grand total row" :

1. Double-click a grand total in a table report.

2. In the Modify Total Function dialog box, select Other from the pull-down menu.
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3. In the Custom Function dialog box, enter text in double-quotes before or after the total function. Concatenate text and function with a plus sign “+”.
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4. In the Modify Total Function dialog box, click the OK button to finish.

Break Totals XE "Table section:break totals" 

 XE "Break Totals" 
To calculate break totals:

1. Select any column in a table.

2. Right-click, and then click Break Total.

3. Configure the Insert Break Total dialog box:

· select a break column from the first pull-down menu (for example, to view totals for each Org, then “Org” is the break column)

· select a data function from the second pull-down menu (for example, to add Total values for each Org, then “Sum” is the data function)

· select a column to be used in the break total calculation (for example, to sum Org values for each Org, “Salary Or Pay Rate” is the column to which to add the break total)
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4. In the Insert Break Total dialog box, click the OK button to finish. Break totals are added to the table report.
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To remove break totals XE "Table section:removing break totals"  in a table report:

1. Highlight a break total row by clicking in the left margin. The break total row is highlighted.

2. Right-click, and then click Remove Row. All related break totals are removed.

To modify a break total’s function XE "Table section:modify a break total’s function" ::

1. Double-click a break total in a table report.

2. In the Modify Total Function dialog box, select a data function from the pull-down menu, and then click the OK button.

To modify the label for a break total XE "Table section:modifying label for a break total" :

· Double-click a break total row label, enter/modify text in double quotes, and then click the OK button.



Formatting Tables XE "Tables:formatting" 
Use the techniques listed below to format table reports.

	Format
	Options

	Resize a column
	· Drag a column’s margin left or right to resize it manually.

or

· Double-click a column’s margin to Auto-Size.

or

· On the Format menu, point to Column, and then click Auto-Size Width or Standard Width.

	Resize a row
	· Select a row (by clicking in the left margin), position the cursor on a row’s edge, and then drag the edge up or down to resize a row manually.

or

· Select a row (by clicking in the left margin); on the Format menu, point to Row, and then click Standard Height to resize a row to a standard size.

Note—Total rows need to be resized separately than regular data rows.

	Font
	On the Format menu, click Font. Select a Font type, Style (Regular, Bold, Italic, Bold Italic), Size, and Effect (Underline, Overline, Double Overline). Columns can have different fonts.

	Numbers, Dates, and Times
	On the Format menu, click Number. Select a number format from the Category area (Number, Currency, Percentage, Date, Time, or Custom).

	Justify data
	Highlight columns, and then click a justification icon on the Format toolbar.

	Suppress duplicate values
	Select a column, right-click, and then click Suppress Duplicates. This feature can be applied to multiple columns.

	Display row numbers
	On the Format menu, click Row Numbers to toggle them on or off.

	Display grid lines
	On the Format menu, click Grid Lines to toggle them on or off. In the dialog box, select properties for horizontal and vertical grid lines: Default, None, or Custom (choose a Color, Width, and Style).


	Display column titles
	On the Format menu, click Column Titles to toggle them on or off.

	Wrap text in a column
	Select a column; then, on the Format menu, click Wrap Text.

	Modify the border around a table
	On the Format menu, click Border and Background. In the Border area, select properties for the border: Default (Black line), None, or Custom (choose a Color, Width, and Style).

	Modify the fill of a table
	On the Format menu, click Border and Background. In the Fill area, select properties for the background: Default (white), None, or Custom (choose a Color).  Select an alternating color if desired.

	Column text color
	Select a column, then on the Format menu, select a text color from the Text Color pull-down menu.


Lesson 2 Summary

In this lesson you have learned:

· Use the Table section to create tabular-style reports based on the dataset in the Results section.

· Use the Sort line or the Sort buttons on the Standard toolbar to sort a table report. When using the Sort line, drag columns into the Sort line.  Once the Sort items are arranged and the sequences are determined (ascending or descending order), click Sort on the Sort line to finish.  When using the Sort buttons, discontiguously select columns in the order you want them sorted, and then click a Sort button on the Standard toolbar.

· Limits can also be set in a Table section for the purposes of filtering the data in the report. Note that limits set in the Results section limit the data available in a Table section. Limits set in a Table section, in turn, limit the data available to reports built off of dataset in a Table section.

· Grand total and break totals can be added to a table report. To insert a grand total, select any column, right-click, and then click Grand Total.  In the Insert Grand Total dialog box, select a data function and a column, and then click OK. To insert a break total, select any column, right-click, and then click Break Total. In the Insert Break Total dialog box, select a break column, a data function, and a column to display the break totals, and then click OK.

· Table reports can be formatted using options available in the Format menu or Format toolbar.

Practice Exercise: Table Section

Objective

Create a query on your own from the Ad Hoc template.  Include a couple of date fields as well as amount fields in your query.  Run your report and view the results in the Results section.  Insert a new Table Report and drag Request items from the Catalog in the Table section into the Outliner.  Practice adding, removing, hiding, unhiding, and reordering columns.  Practice adding grand totals and break totals to columns.  Practice the formatting techniques taught in the lesson.

Try this exercise on your own.  If you need help, refer back to the manual for the specifics on how to perform the various functions.  Ask the instructor for more help if necessary.


NOTES:


Brio does not let you copy/paste a single column.  The copy command will copy the entire table by default.  One trick is to create a table section and add only the column you want to copy.  After you’ve pasted the values to your target file, you can delete the table section from the Brio document.

Chapter 4   Pivot Section XE "Pivot section" 
Upon completion of this unit users will be able to:

· Identify the following key terms:

· Pivot report

· Pivot Outliner

· Dimension

· Surface Values and Underlying Values

· Drill Anywhere

· Drill to Detail

· Predefined Drill Paths

· Create simple pivot reports

· Pivot a report

· Apply totals and subtotals to pivot reports

· Understand the difference between surface values and underlying values

· Create cumulative totals

· Create increase columns

· Sort data in a pivot report

· Instantly create a chart from a pivot report

· Format a pivot report

· Drill into the underlying pivot data

· Spotlight exceptional pivot values

· Group pivot report labels together

· Summarize pivot data various ways using data functions

· Sort pivot data various ways using the Sort Line

· Focus on specific pivot data

· Hide irrelevant pivot data

Lesson 1: Creating Pivot Reports

Lesson Objectives

Upon completion of this unit users will be able to:

· Identify the following key terms:

· Pivot report

· Pivot Outliner

· Dimension

· Surface Values and Underlying Values

· Create simple pivot reports

· Pivot a report

· Apply totals and subtotals to pivot reports

· Understand the difference between surface values and underlying values

· Create cumulative totals

· Create increase columns

· Sort data in a pivot report

· Instantly create a chart from a pivot report

· Format a pivot report

About Pivot Reports

A Pivot report XE "Pivot section:Pivot Report"  is an analytical tool that resembles spreadsheets or crosstab reports. A pivot report overlays a dynamic datacube, which allows data to be sliced and diced for ad hoc, interactive, and multidimensional analysis.  Pivot reports consist of side labels, top labels, and facts. Side and top labels are referred to as dimensions and have handles that can be pivoted to the top or side of the report. A pivot report is summarized at the dimension levels.

The pivot Outliner XE "Pivot section:Pivot Outliner"  consists of three panes: Side Labels, Top Labels, and Facts. Add items from the Catalog pane to the Outliner to create a report.
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Creating a Pivot Report XE "Pivot section:creating a Pivot Report" 
To create a pivot report:

1. On the Insert menu, click New Pivot.

2. Click Outliner on the Section Title bar to display the Outliner if it is not displayed.

3. Drag Request items from the Catalog to the Side Labels, Top Labels, and Facts panels of the Outliner.

· Multiple items can be added to any panel.

· Items are hierarchically ordered in the sequence in which they appear in the Outliner panels.

· Side and top labels are usually textual.

· Fact items are summed by default.
Pivot a Report

Side labels can become top labels and visa versa using the pivot feature.

By dragging a dimension to a new location, the pivot report is recalculated.

To pivot a dimension XE "Pivot pivot a dimention" :

· Drag a dimension’s handle to a new location.

To reorder fact items in a pivot report XE "Pivot section:reording fact items" :

· Click a fact’s column heading in a report, and then drag it to a new position.

To remove items from a pivot report XE "Pivot section:removing items from a Pivot" :

· Right-click an Outliner item, and then click Remove.
Totals XE "Pivot section:totals" 
Totals can be calculated for any dimension in a pivot report. When an inner dimension is totaled, subtotals are created for each of the label values in the outer dimensions.

An intelligent data function (aggregate) is applied to a total. For example, the total of a column of averages is an average itself, rather than a sum total. The total function can be modified, if needed.

   
[image: image59]
To add totals XE "Pivot section:adding totals"  to a pivot report:

1. Select a side or top dimension by clicking a handle in a report.

2. Right-click, and then click Add Totals (or click the Grand Total button on the Standard toolbar).

Total Functions XE "Pivot section:total functions" 
Column or row totals added to a pivot report are aggregates (literally, totals of totals), and can be recalculated using different data functions. In the example below, Salary Or Pay Rate values for each Pay Plan are averaged and displayed at the bottom of the columns.
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NOTE Null values in a pivot report (empty values for which no data exists) are not treated as equal to zero in a total function calculation.

To modify a total function XE "Pivot section:modifying total functions" :

1. Alt-click a total label in a report. The total row or column is highlighted.

2. Right-click, point to Data Functions, and select a data function from the list (Sum, Average, Count, Max, Min, % of Column, % of Row, % of Grand, Increase, % Increase, Non-Null Average, Null Count, or Non-Null Count).

Surface versus Underlying Values XE "Underlying Values" 

 XE "Surface Values" 
Totals are calculated based on surface values (what is displayed in a pivot report) or underlying values (values in the Results section). When underlying values are used, the aggregate values may appear incongruous with the aggregate surface values of the pivot report. In other words, the total values appear incorrect. To calculate total values based on the aggregate values in the pivot report, use surface values. For example, if you apply a surface average to a total, the total will be converted to the average of the surface values in the corresponding row or column of the pivot report.

IMPORTANT All totals in the report are either based on surface values or underlying values. Only one method can be used within a report.

To generate totals based on surface values in a pivot report XE "Pivot section: generate totals based on surface values" :

· On the Pivot menu, click Use Surface Values.

Cumulative Totals XE "Pivot section: cumulative totals" 
Cumulative totals can be calculated in a pivot report, restarting at zero for each new dimensional group. In the example below, Salary Or Pay Rate values are cumulative in the Cumulative Salary Total of the Salary Or Pay Rate column. Totals are only cumulative within each Pay Plan.
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To add a cumulative total XE "Pivot section:adding a cumulative total"  column to a pivot report:

1. Highlight the fact columns in a pivot report, right-click, and then click Add Cume.

2. In the Pivot Cume dialog box, type a label name, select a dimension to define the scope, and then click the OK button.

· A new fact named "Cume of {item name}" appears in the report.

· The new cume item maintains a cumulative running sum of the original fact item.

TIP Cumes work best when all dimensions are located at the top or side of a pivot report, and Fact column headings are placed orthogonally.

Calculating Increase XE "Pivot section:Increase"  and Percent Increase XE "Pivot section:percent increase" 
The Increase or % Increase between two columns/rows at the end of a row/column can be calculated using the Increase and % Increase total functions. These functions can be applied only at the innermost dimensional level.

To calculate an increase XE "Pivot section:calculating an increase item"  item:

1. Create a total row or column.

2. Alt-click (Option-click for Macintosh) the total row or column, right-click, point to Data Function, and then click Increase or % Increase.

Sorting XE "Pivot section:sorting" 
Use the Sort buttons to quickly sort side or top labels, or specify complex referential sorts using the Sort line. Sort labels alphabetically, or based on facts in the report. Although sort conditions for each report label are not displayed simultaneously in the pivot Sort line, apply simultaneous conditions by choosing each label from the “Sort” pull-down menu and applying conditions.

To sort labels alphabetically using the Sort buttons XE "Pivot sections:sort labels using the Sort buttons" :

· Select a label to sort, and then click the Ascending or Descending Sort button on the Standard toolbar.

To apply sort conditions using the Sort line XE "Pivot sections:sort labels using the Sort line" :

1. Click Sort on the Section Title bar to view the pivot Sort line.

2. Configure the Sort line.

· Select a label to sort from the first pulldown menu.

· Select Label from the ‘by’ pull-down menu to sort the label alphabetically by label, or choose a Fact item from the ‘by’ pull-down menu to sort referentially by numeric values. The data is sorted according to the specification. The ‘using’ pull-down menu is disabled when Labels are sorted.

· If desired, choose a data function from the 'using' menu when sorting by Fact items. For example, choose “Count” if the fact column in the report is displaying a count.

· Click a Sort order button to specify ascending or descending sort order.

IMPORTANT The Sort order is based on the aggregated value of all labels in a dimension.

“Chart This Pivot XE "Pivot:Chart This Pivot" ” Feature

Charts can be automatically generated from pivot reports.

To automatically chart a pivot report:

· On the Insert menu, click Chart This Pivot. A new bar chart is created using the data from the pivot report, and the chart section is displayed automatically.
Formatting Pivot Reports XE "Pivot section:formatting Pivot Reports" 
The following table lists common formatting techniques:

	Format
	Options

	Resize a column
	· Drag a column’s margin to the left or right to resize it manually.

or

· Double-click a column’s margin to Auto-Size.

or

· Select a label; on the Format menu, click Auto-Size Width.

	Resize a row
	· Drag a row’s margin up or down to resize it manually.

or

· Double-click a row’s margin to Auto-Size.

or

· Select a label in the report; on the Format menu, click Auto-Size Height to resize a row to a standard size.

Note—Total rows need to be resized

separately than labels.

	Font
	On the Format menu, click Font.  Select a Font type, Style (Regular, Bold, Italic, Bold Italic), Size, and Effect (Underline, Overline, Double Overline). Labels can have unique font styles.

	Numbers, Dates, and Times
	Select a numeric label or fact in the report.  On the Format menu, click Number. Select a number format from the Category area (Number, Currency, Percentage, Date, Time, or Custom).


	Justify data
	Select a report element, and then click a justification icon on the Format toolbar.

	Display border lines XE "Pivot section:displaying border lines" 
	Select a report element; on the Format menu, point to Borders, and then select a border option (None, Horizontal, Vertical, Horz and Vert, 3-D Raise, or 3-D Sink).

	Change the position of data labels
	On the Format menu, point to Data Labels, and then click an option (None, Across Top, or Down Side).

	Display corner labels
	On the Format menu, point to Corner Labels, and then click an option (None, Top, Side, or Both).

	Format an entire column or row (for example, a total row)
	Alt-click (Windows) on a label, and then apply a format from the Format menu or Format toolbar.

	Rename a label XE "Pivot section:renaming a label" 
	Double-click a label, enter a new label name in the dialog box, and then click the OK button.

	Add color
	Select a report element, and then select a color from the Line Color, Fill Color, or Text Color pull-down menus on the Format toolbar.


Lesson 1 Summary

In this lesson you have learned:

· A pivot report overlays a dynamic datacube, which allows data to be sliced and diced for ad hoc, interactive, and multidimensional analysis.

· To create a pivot report, add a Pivot section to the document by clicking New Pivot on the Insert menu. Next, drag Request items from the Catalog into the pivot Outliner. Click Outliner on the Section Title bar if the Pivot Outliner is not displayed. The Pivot Outliner consists of three panels: Side Labels panel, Top Labels panel, and a Facts panel.  Populate the Facts panel with numeric data that can be aggregated.  Populate the Label panels with textual data—these become the dimensions of the Pivot report.

· Any dimension in a pivot report can be totaled. To total a dimension, select a dimension’s handle and click the Grand Total button on the Standard toolbar. When an inner dimension is totaled, subtotals are created for each of the categories in the outer dimensions. Intelligent data functions (aggregates) are applied to totals; meaning, whatever data function is applied to the column, the same is applied to the total value. To change the data function of a total row, highlight a total row (Alt-click for Windows), right-click, and then select a data function.

· Add cumulative running totals to a pivot report, and break them by dimension to restart at each dimensional grouping in the report.

· Use the Sort line to sort labels based on facts in the pivot report. Use the Sort buttons on the Standard toolbar to quickly sort a dimension alphabetically.

· A quick way to view a pivot report in the form of a bar chart is to use the “Chart This Pivot” feature. Simply create a pivot report, and then on the Insert menu, click Chart This Pivot.

· The Pivot section has several formatting capabilities. Some useful features include displaying fact headings (data labels) across the top or down the side, displaying side and top corner labels, defining border styles, and adding color to lines, text, and background.

Extra Practice

· Generate a new query and insert a new Pivot section.

· Click and drag Side and Top labels as well as Facts into your pivot.

· Practice using the techniques taught in this section.
Lesson 2: Analyzing Pivot Data XE "Analyzing Pivot Data" 
Lesson Objectives
Upon completion of this lesson users will be able to:

· Identify the following key terms:

· Drill Anywhere

· Drill to Detail

· Predefined Drill Paths

· Drill into the underlying data

· Spotlight exceptional values

· Group report labels together

· Summarize data various ways using data functions

· Sorting data various ways using the Sort Line

· Focus on specific data

· Hide irrelevant data

Introduction

Pivot reports also allow you to spotlight exceptional values, focus on and group dimensions, and recalculate on the fly how the data is summarized, to gain customized views of the data. Use these tools to present data in different context and with heightened emphasis.

Drilling Features XE "Drilling features"  XE "Analyzing Pivot Data:drilling" 
There are three drilling features:

· Drill Anywhere

· Drill Up

· Drill to Detail

· Pre-defined drill paths

Drill Anywhere XE "Drilling features:Drill Anywhere" 
Drill Anywhere analysis enables a user to progressively break down dimensions by selected categories. It is an essential analysis tool that reveals the makeup of a Request item as a sum of constituent parts.

To Drill Anywhere:

1. Select one or more labels from the same dimension to drill into.
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2. Right-click, point to Drill Anywhere, and click an item to drill into.

· All extraneous labels are hidden, except the selected label(s).

· The selected label(s) are displayed broken down by the drill item(s).

· In the Outliner, the specified drill item is added to the appropriate panel, and the drilled item is identified with a drill-bit icon.
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Drill Up XE "Drilling features:Drill Up" 
The Drill Up feature reverses a drill in one step. This is another powerful analysis tool, which allows a user to move from close detail immediately to seeing the big picture.

To Drill Up:

· Right-click the new item added to the report after drilling down (select the Outliner item or the dimension handle), and then click Drill Up.

· The dimension is restored in the pivot report.

· Entire dimensions can be restored, but not single dimension labels.

· It is possible to drill up from any level of a hierarchy which has been successively drilled down.

Predefined Drill Paths

A predefined drill path XE "Drilling:predefined drill paths"  enables a user to go directly to the next item to drill down into when working with dimensional analysis.

To drill down using predefined drill paths:

1. Select one or more labels from the same dimension, right-click, and then click Drilldown into <item>.

2. View the data added to the pivot report.

NOTE A relational database is required in order to use the predefined drill path feature.

Spotlighting XE "Spotlighting"  XE "Analyzing Pivot Data:spotlighting" 
Some figures can be cause for celebration, or concern. Highlight these important numbers so they stand out in the reports by applying color and font styles with the Spotlighter. Spotlighter formats are applied conditionally, by building an equation and applying the constraint to the report.

To spotlight exceptional values:

1. Select a Fact column in the report.
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2. On the Format menu, click Spotlighter.
3. In the Spotlighter window, build a conditional format - 

· Choose a comparison operator from the pull-down menu
· Enter a comparison value in the edit field

· Choose an exception text format by clicking the font style buttons and color boxes

· Add formatting styles and colors to spotlight the data. The sample text in the dialog box previews the spotlighter formatting

4. Click the green check mark button to apply.
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5. View the spotlighted values in the report.
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NOTE Multiple conditions can be applied to a single Fact column.

To modify Spotlighter formats XE "Spotlighting:modifying formats" :

1. Select a Fact column in a pivot report that contains a Spotlighter format.

2. On the Format menu, click Spotlighter. The Spotlighter window appears, displaying the formats applied to the Fact column in the format scroll box.

3. In the Spotlighter window, double-click the spotlighter format (to be modified) in the scroll box. All conditional formats applied to the Fact column are captured to the editor.

4. Make any desired changes to the condition or format, and then click the green check mark button to reapply the modified spotlighter format. The modified format is reapplied to the Fact column.

To copy Spotlighter formats XE "Spotlighting:copying formats" :

1. Select a Fact column in a pivot report that contains a Spotlighter format.

2. In the Spotlighter window, select the spotlight formats (to be copied) in the scroll box, and then click the Capture button. The spotlighter format is captured to the editor.

3. Select a new Fact column in a pivot report as the target area to apply the copied Spotlighter formats. The target area can be in the same report or a different one.

4. In the Spotlighter window, click the Restore button. The captured formats are applied to the selected report element.

To remove a Spotlight XE "Spotlighting:removing a Spotlight"  from a selected Fact column:

1. Select a spotlighted Fact column.

2. On the Format menu, click Spotlighter. The Spotlighter formats applied to the Fact column appear in the scroll box of the Spotlighter window.

3. In the Spotlighter window, select the format to remove in the scrollbox, and then click the Remove button on the Standard toolbar. The Spotlighter format is removed from the selected Fact column.
Grouping XE "Pivot section:grouping"  XE "Analyzing Pivot Data:grouping" 
Merge labels in a pivot dimension by using the Group feature. When combined, the data associated with labels is aggregated, creating a new summary category label. With grouping, only the view of the data is changed. Labels can be easily unwrapped and restored to their original values.

To group dimension labels:

1. Select labels in a single dimension (contiguously or discontiguously).
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2. Click the Group Items button on the Standard toolbar (listed under the Pivot button). The selected labels and their associated Facts are combined. The resulting label is displayed with an asterisk (*) to indicate a grouping.

3. Rename the group by double-clicking the group’s label and entering a new label name in the Set Label Item dialog box. Click the OK button to finish.
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To ungroup dimension labels XE "Pivot section:ungrouping dimension labels" :

· Select a group’s label, and then click the Group Items button on the Standard toolbar. The group’s original labels are restored.
Data Functions XE "Pivot section:data functions" 
Request items added to the “Facts” panel of a pivot Outliner are automatically summarized in the report, which means the underlying data (listed in the Results section) is summed, counted, averaged, etc., based on the dimensions in the Pivot report. The data function applied to a “Fact” item can be modified if needed.

The same Request item can be used multiple times as a Fact in a Pivot report, displaying different data functions.

To modify a data function applied to a Fact:

· Select a Fact column, right-click, point to Data Function, and then click a function (Sum, Average, Count, Max, Min, % of Column, % of Row, % of Grand, Non-Null Average, Null Count, or Non-Null Count).

Focusing on/Hiding Pivot Labels XE "Pivot section:focusing on/hiding pivot labels" 
Emphasize or exclude data using the Focus and Hide features. These features are useful when a user is interested in a particular area, and wants to remove data, which is less significant or distracting. “Hide” hides selected labels from a report. “Focus on” hides all but the selected label.  Hidden labels are removed from the report, but the Request items remain in the Outliner and the data can be restored at any time. To focus on (or hide) contiguous or discontiguous labels, they must be part of the same dimension.

To focus on (or hide) labels:

· Select one or more labels in a dimension to focus on (or hide from view), right-click, and then click Focus on Items (or Hide Items).

To show hidden labels XE "Pivot section:showing all hidden labels"  in a single dimension:

· Select the dimension in the Pivot Outliner, right-click, and then click Show Hidden Items.

To show all hidden labels, from multiple dimensions:

· Select any label in a report, right-click, and then click Show All Items.  All labels in all dimensions are restored in the report.
Lesson 2 Summary

In this lesson you have learned:

· Once a Pivot report is built, analyze the data by drilling into labels. To drill into data, select a label (or labels) from a single dimension, right-click, point to Drill Anywhere, and select an item. The report is then focused on the selected labels and a new dimension is added. The Spotlighter highlights exceptional values in a Pivot report.

· Combine data for multiple labels together using the Group feature. To group labels, select the labels to group, and then click the Group button on the Standard toolbar. To ungroup, select a group’s label, and then click the Group button on the Standard toolbar.

· Pivot reports summarize the data in the Results section. Numerical items are aggregated across dimensions. In a Pivot report, items in the Fact panel are aggregated to the level of detail provided by the dimensions (Side and Top Labels). Fact values are calculated using data functions, such as sum, count, average, minimum, etc.

To narrow down a Pivot report, use the Focus/Hide features. These features limit the Pivot report to specific labels. To Focus on/Hide labels, select one or more labels in a dimension to focus on (or hide from view), right-click, and then click Focus on Items (or Hide Items). 
Practice Exercise: Pivot Section

Objective


Learn to create and manipulate Pivots.  Using a document that has a pre-built Pivot, arrange the Pivot for easy printing.   Add new computations to the pivot and use the Spotlighter to highlight the data.

· Open the NASA Labor Cost Voucher document.
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· Process the query using your center code.

· Focus on the “Lbr Add by Dept/Bur” Pivot

· Change the Pivot to display the fact vertically for easy printing

· Right-click an open area of the Pivot

· Choose “Data Labels > Down Side” from the hot menu

· Resize the report for portrait printing

· View the report in print preview mode

· Edit the header and add the center code

· Double click the header

· Place you curser at the end of the current entries in the editor

· Add a line by pressing “Enter”

· Type “Center Codes for this report = “

· Click the limit button (funnel icon)

· Choose “Query – Bureau” from the limit list

· Click “OK’ and “OK”

· Focus on the “Lbr Pay Cd by Dept/Bur” pivot

· Left-click the pivot section on the section catalog

· Add Org to the pivot using the “Drill” function

· Left-click the Bureau column to focus

· Right-click and choose “Drill Anywhere > Org” from the hot menu

· Remove side labels after Org

· Add “Pay Code Hours” to the facts

· Drag the field from the catalog to the facts area of the outliner

· Select the column just added; right-click and choose “Data Function > Average” from the hot menu

· Change the column heading to “Average Pay Code Hours”

· Double-click the heading and type in the new text

· Reposition the new “Average” column to the right of the “Total Pay Hours” column using the outliner

· Create an “Average Hourly Pay” computed item

· Right-click an open area of the Pivot and choose “Add Computed Item”

· Use the computed item editor’s “reference” and math keys to write the following formula:

· Total_Payroll_Hours / Detail_Record_Cnt  

· Name the computed item “Average Hourly Pay”

· Format the “Average Hours” column to two decimals

· Select the column with a left-click to any cell

· Right-click and choose “Number” from the hot menu

· Select the appropriate format

· Use the Spotlighter to highlight any “Average Hours” cells that exceed 15

· Select the “Average Hours” column

· From the “Format” menu, choose “Spotlighter…”

· In the Spotlighter set up tool set the “Operator” to “>” (greater than)

· In the “Value” box, type “15”

· In the “Styles” area, select:

· Bold

· Red Font color

· An equally annoying, but contrasting background color

· Click the green check mark to apply

Save the document.

Leave the document open for the next exercise.


NOTES:


When “drilling” a pivot, the dimension you start with automatically becomes a limit for the pivot.  This is the same as using the “focus” feature.  If you want to add a new dimension without limiting the pivot, do not drill; drag the new dimension from the catalog to the pivot outliner.

Chapter 5   Chart Section XE "Chart section" 
Upon completion of this unit users will be able to:

· Identify the following key terms:

· Chart reports

· Chart Outliner

· Create simple charts, including

· vertical and horizontal bar charts

· vertical cluster bar charts

· vertical and horizontal stacked bar charts

· pie charts

· area charts

· stacked area charts

· ribbon charts

· bar-line charts

· Modify chart elements (bars, lines, etc.)

· Manipulate charts

· Modify chart properties

· Formatting charts

· Instantly create a pivot report from a chart

· Drill into the underlying chart data

· Group chart report labels together

· Sort chart data various ways using the Sort Line

· Summarize chart data various ways using data functions

· Focus on specific chart data

· Hide irrelevant chart data

Lesson 1: Creating Charts

Lesson Objectives

Upon completion of this lesson users will be able to:

· Identify the following key terms:

· Chart Section

· Chart Outliner

· Create simple charts, including

· vertical and horizontal bar charts

· vertical cluster bar charts

· vertical and horizontal stacked bar charts

· pie charts

· area charts

· stacked area charts

· ribbon charts

· bar-line charts

· Modify chart elements (bars, lines, etc.)

· Manipulate charts

· Modify chart properties

· Format a chart

· Instantly create a pivot report from a chart

About Charting

Chart reports XE "Chart section:chart reports"  are fully interactive, three-dimensional views of data. Use the charts to convert your raw data into eloquent, visual information, which delivers immediate impact.

With a varied selection of chart types, and a complete arsenal of OLAP tools like group and drilling, the Chart section is built to support simultaneous graphic reporting and ad-hoc analysis. The look and architecture of a chart can be changed literally by clicking a button.

Add, move, stack, cluster, repaint, focus on, and drill into chart objects to gain customized views of the data. Apply new colors and rearrange axes to view data from a completely different perspective.

In the Chart section, the following chart types can be created:

· Vertical Bar

· Horizontal Bar

· Vertical Stacked Bar

· Horizontal Stacked Bar

· Vertical Cluster Bar

· Pie

· Stacked Area

· Area

· Line

· Ribbon

· Bar-Line

The chart Outliner consists of three panels:

· Y-Facts XE "Chart section:Y-Facts" 
· X-Categories XE "Chart section:X-Categories" 
· Z-Cateogories XE "Chart section:Z-Categories" 
Items in the Y-Facts panel generate the graphical elements (bars, pie slices, lines, etc.) in the chart. Items in the X- and Z-Categories panels generate the axes labels. Multiple items can be added to a panel.  Categories are hierarchically ordered in the sequence in which they appear in Outliner panels.

NOTE The Outliner adjusts according to the type of chart selected.

To add a Chart section XE "Chart section:creating charts" 

 XE "Chart section:adding a Chart section"  to a document:

· On the Insert menu, click New Chart. A blank Chart section is created.
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Vertical and Horizontal Bar XE "Chart section:bar"  Charts

Vertical and horizontal bar charts in 2- or 3-dimensions can be created in the Chart section. A horizontal bar XE "chart report types:horizontal bar"  chart is a vertical bar chart rotated 90 degrees. Vertical bar charts are the Chart section’s default chart type. Bar values are based on Fact items in the chart Outliner, and axes labels are derived from X- and Z-Categories. Multiple items can be added to an Outliner panel.

2-Dimensional Vertical Bar XE "Chart section:vertical bar"  Chart
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3-Dimensional Vertical Bar Chart XE "Chart section:3-dimensional vertical bar" 
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2-Dimensional Horizontal Bar Chart XE "Chart section:2-dimensional horizontal bar" 
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Creating Bar Charts

To create a 2- or 3-dimensional vertical or horizontal bar chart:

1. On the Insert menu, select New Chart, then click the down arrow on the Chart Type pull-down list (located on the Section toolbar), and select Vertical Bar or Horizontal Bar.

2. Drag each Request item to be included in the chart from the Catalog to an Outliner panel:

· Drag quantifiable Request items to the Facts panel.

· Drag non-quantifiable Request items to the X-Categories panel to create a two-dimensional chart.

· If desired, drag a Request item to the Z-Categories panel to add a third dimension.

3. Select Legend on X, Legend on Y, or Legend on Z in the Section toolbar to colorize the bars.

Bar Chart Properties

To modify bar chart properties:

1. Select a bar, right-click, and then click Properties.
2. In the Patterns tab of the Properties dialog box, select a Fill Pattern (Automatic, None, Custom) and Foreground color (double-click the color box, and then select a color) for the selected bar.
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3. In the Data Labels tab of the Properties dialog box, select options for displaying data values.
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Bar Gaps

To add/close the gap between bars XE "Chart section:adding/closing the gap between bars" :

· Select any bar, right-click, and then click Show Bar Gap.

Vertical Clustered Bar Charts

Vertical clustered bar XE "Vertical Cluster bar" 

 XE "Chart section:vertical cluster bar"  charts are useful in making complex visual comparisons. By clustering items and assigning a different color to each, contrasts are effectively displayed among comparable items.

Vertical Cluster Bar Chart
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Creating Clustered Bar Charts

To create a vertical cluster bar chart:

1. On the Insert menu, select New Chart.

2. On the Format menu, select Chart Type, and then select Vertical Cluster Bar.
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3. Drag each Request item to be included in the chart from the Catalog to an Outliner panel:

· Drag quantifiable Request items to the Facts panel.

· Drag non-quantifiable Request items to the X-Categories and Z-Categories panels.

· Facts are itemized by Z-Categories and grouped by X-Categories.  At least two categories are needed. Populate both the X- and Z-Categories panels or populate the Z-Categories panel only with two or more Request items.

4. Select Legend on X, Y, or Z  in the Section toolbar to colorize the groups of bars.

Vertical and Horizontal Stacked Bar XE "Chart section:horizontal stacked bar"  Charts

Stacked bar charts offer similar complexity to clustered charts. By stacking Fact values in a chart and assigning a different color to each one, a sum of several indicators is visually emphasized. Stacked bars can be viewed vertically or horizontally.

Vertical Stacked Bar XE "Chart section:vertical stacked bar"  Chart
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Horizontal Stacked Bar Chart
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Creating Stacked Bar Charts

To create a vertical or horizontal stacked bar chart:

1. On the Insert menu, select New Chart, and then click the down arrow on the Chart Type pull-down list (located on the Section toolbar).

2. On the Format menu, select Chart Type, and then select Vertical Stack Bar or Horizontal Stack Bar.

3. Drag each Request item to be included in the chart from the Catalog to an Outliner panel:

· Drag quantifiable Request items to the Facts panel.

· Drag non-quantifiable Request items to the X- and Z-Categories panels.

· Facts are itemized within each bar by Z-Categories and all bars are itemized by X-Categories. At least two categories are needed.  Populate both the X- and Z-Categories panels or populate the Z-Categories panel only with two or more Request items.

4. Select Legend on Y in the Section toolbar to colorize the sections within a bar.

Pie Charts XE "Chart section:pie" 
Pie charts are representations of fractional Facts relative to a whole. In a pie chart, categories represent itemized slices of the pie and Facts define the quantitative whole of the pie. A pie chart is two-dimensional and therefore only a Y-Facts and X-Categories panel exist in the Outliner.
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Creating Pie Charts

To create a pie chart:

1. On the Insert menu, select New Chart.

2. On the Format menu, select Chart Type, and then select Pie.

3. Drag each Request item to be included in the chart from the Catalog to an Outliner panel:

· Drag quantifiable Request items to the Facts panel.

· Drag non-quantifiable Request items to the Categories panel.

 Pie Chart Properties

To modify pie chart properties:

1. Select a pie slice, right-click, and then click Properties.

2. In the Patterns tab of the Properties dialog box, select a Fill Pattern (Automatic, None, Custom) and Foreground color (double-click the color box, and then select a color) for the selected pie slice.
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3. In the Data Labels tab of the Properties dialog box, select display options:

· show labels, values, and/or percentages for all pie slices

· draw a line from the selected pie slice(s) to the label(s).
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Pulling Out Pie Slices

To pull out a pie slice XE "Chart section:pulling out a pie slice" :

· Select a pie slice, right-click, and click Pull Out Slice.

Line XE "Chart section:line"  Charts

Think of a line chart as connecting the tops of bars in a bar chart. Line charts are effective for expressing highs and lows comparatively in a continuum. Line charts default to 2-dimensions for optimum readability.
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Creating Line Charts

To create a line chart:

1. On the Insert menu, select New Chart
2. On the Format menu, select Chart Type, and then select Line.

3. Drag each Request item to be included in the chart from the Catalog to an Outliner panel:

· Drag quantifiable Request items to the Facts panel. Facts determine the height of the line.

· Drag non-quantifiable Request items to the X- and Z-Categories panels. X-Categories itemize the line sections and Z-Categories create multiple lines.

4. Select Legend on Y in the Section toolbar to assign a different color to each line.

Modifying Line Chart Properties

To modify line chart properties:

1. Click a line in a chart, right-click, and then click Properties.

2. In the Properties dialog box, select option in the tabs:

· The Patterns tab provides options to change the line style and markers.
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· The Axis tab gives the option to plot values on the left or right axis.
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· The Data Labels tab provides the options to show/hide line values in the chart in a variety of placements.
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Shifting Line Markers XE "Chart section:line markers" 
To shift the position of line markers:

1. Double-click a line chart.

2. In the Bar Chart tab of the Properties dialog box, click Shift points to Left or Shift Points to Center in the Shift area.

Area Charts XE "Chart section:area" 
Area charts are very similar to line charts, but with a few visual differences.  Area charts are line charts with the area under the line filled in.

2-Dimensional Area Chart
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Creating Area Charts

To create a 2- or 3-dimensional area chart:

1. On the Insert menu, select New Chart.

2. On the Format menu, select Chart Type, and then select Area.
3. Drag each Request item to be included in the chart from the Catalog to an Outliner panel:

· Drag quantifiable Request items to the Facts panel. Facts determine the size of area.

· Drag non-quantifiable Request items to the X-Categories panel. X-Categories itemize the area into a 2-dimensional chart.

· If desired, drag non-quantifiable Request items to the Z-Categories panel to create a third dimension. Z-Categories create multiple area sections.

4. Select Legend on Z in the Section toolbar to colorize the area sections.

Modifying Area Chart Properties

To modify area chart properties:

1. Select a chart area, right-click, and then click Properties.

2. In the Patterns tab of the Properties dialog box, select a fill pattern and area color, and then click the OK button.
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Stacked XE "Chart section:stacked area"  Area Charts

Area charts can be stacked in the same manner as bar charts.
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Creating Stacked Area Charts

To create a stacked area chart:

1. On the Insert menu, select New Chart
2. On the Format menu, select Chart Type, and then select Stacked Area.

3. Drag each Request item to be included in the chart from the Catalog to an Outliner panel:

· Drag quantifiable Request items to the Facts panel.

· Drag non-quantifiable Request items to the X- and Z-Categories panels.

· Area sections are determined by Z-Categories.

· All area sections are itemized by X-Categories.

· Populate both the X- and Z-Categories panels or populate the Z-Categories panel only with two or more Request items.

4. Select Legend on Y in the Section toolbar to colorize the area sections.

Ribbon XE "Chart section:ribbon"  Charts

Ribbon charts are also very similar to line charts, but with a few visual differences. Ribbon charts are line charts with a 3-dimensional line style.
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Creating Ribbon Charts

To create a 2- or 3-dimensional ribbon chart:

1. On the Insert menu, select New Chart
2. On the Format menu, select Chart Type, and then select Ribbon.

3. Drag each Request item to be included in the chart from the Catalog to an Outliner panel:

· Drag quantifiable Request items to the Facts panel. Facts determine the size of area.

· Drag non-quantifiable Request items to the X-Categories panel to itemize within a ribbon.

· If desired, drag non-quantifiable Request items to the Z-Categories panel to create multiple ribbons.

4. Select Legend on Z in the Section toolbar to colorize the ribbons.

Modifying Ribbon Chart Properties

To modify ribbon chart properties:

1. Select a ribbon, right-click, and then click Properties.

2. In the Patterns tab of the Properties dialog box, select a fill pattern and ribbon color, and then click the OK button.

[image: image109.png]Fatters |

Area
€ Automalic
€ None

@ Custom

FilPater:  [Soid ]

Foregiound: R
Preview

Zoom: 100%





Bar-Line XE "Chart section:bar-line"  Charts

Compare and contrast multiple, different-scaled Facts in a single chart using bar-line charts. Facts determine the height of the bars and position of the line markers. The first Fact in the Outliner is charted as bars and scaled on the primary (left) axis in the chart. The second Fact in the Outliner is charted as a line and scaled on the secondary (right) axis in the chart. X-Categories itemize the bars and line markers. Bar charts can also be 2- or 3-dimensional.
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Creating Bar-Line Charts

To create a 2- or 3-dimensional bar-line chart:

1. On the Insert menu, select New Chart
2. On the Format menu, select Chart Type, and then select Bar-Line.

3. Drag each Request item to be included in the chart to an Outliner panel:

· Drag the first quantifiable Request item from the Catalog to the Facts panel to be charted as bars.

· Drag the second quantifiable Request item from the Catalog to the Facts panel to be charted as a line.

· Drag non-quantifiable Request items from the Catalog to the X-Categories panel to itemize the bars and line markers.

4. To modify the bar or line properties, right-click a chart element (bar or line), and then click Properties. Configure the tabs in the Properties dialog box. Properties can also be modified by double-clicking the content area and configuring the settings in the Bar Chart tab of the Properties dialog box.

Manipulating Charts XE "Chart section:manipulating charts" 
The table below describes various ways to manipulate charts.

	Select
	How To

	Modify a chart’s layout
	• Reorder Request items within an Outliner panel by dragging.

or

• Interchange X- and Z-Categories by dragging items between the panels.

	Remove a chart item
	Select an Outliner item, right-click, and then click Remove.

	Select a chart element (bar, pie slice, line, or area)
	Click directly on the element.

	Select X- or Z-Category labels in a chart
	Click a label in the content pane. One label appears selected, however, all labels along the axis are affected.

	Select left or right axis values in a chart
	Click directly on any axis value in the content pane. All values within the axis are highlighted and affected.

	Move a chart object (text box, Legend, or axis label)
	Drag an object to a new position in the content pane.



	Resize an object
	Select an object in the content pane, place the cursor over a graphic resize handle, and the drag it open or closed.


General Chart Properties XE "Chart section:general chart properties" 
Chart properties can be modified at any time. Set the following general chart properties by configuring the General tab in the Properties dialog box:

· change a chart’s title and/or subtitle

· hide/display a chart’s legend

· display a chart as 2- or 3-dimensional

· display/hide a border around the chart

· resize a chart automatically as the application window is resized

· display specific chart planes

· rotate a chart

Modifying General Chart Properties

To modify general chart properties:

· On the Chart menu, click Properties, and then make selections in the General tab of the Properties dialog box.
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To manipulate X- and Z-Category labels:

· On the Chart menu, click Properties, and then make selections in the Labels Axis tab of the Properties dialog box.
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To manipulate the left and right axis values XE "Chart section:manipulating the left and right axis values" :

· On the Chart menu, click Properties, and then make selections in the Values Axis tab of the Properties dialog box.
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Other Formatting XE "Chart section:formatting charts"  Techniques

The table below lists other formatting techniques applicable to all charts.

	Format
	How To

	Resize a chart
	Click on the workspace, outside of a chart, and then drag a graphic resize handle.

	Change chart colors
	· For chart elements (for example, a bar) and planes: click on an element or plane, and then select a Line and/or Fill color on the Format menu.

· For chart objects (for example, text boxes, labels, axis values): click an object, and then select a Fill and/or Text color from the Format menu.

· For Legends: click anywhere in a Legend, and then select a Line or Fill color on the Format menu.

	Justify axis values
	Select an axis value, right-click, and then select a justification (Left, Center, or Right / Top, Middle or Bottom / Horizontal, Vertical, Vertical Rotated Up, or Vertical Rotated Down)

	Change the number format of axis values or labels
	Select an axis value, right-click, and then click Number. In the Properties dialog box, select a format from the list of categories (Number, Currency, Percentage, Date, Time, Custom)

	Change the font of axis values or labels
	Select an axis value or label, right-click, and then click Font. In the Font dialog box, select a Font, Style (Regular, Italic, Bold, Bold Italic), Size, and Effect (Underline, Overline,

Double Overline).

	Change the look of a line or line marker
	Select a line, right-click, and then click Properties. In the Patterns tab of the Properties dialog box, select options for the line (Color, Width, and Style) and the markers (Style, Size, Border color, Fill color).

	Rotate a chart

Note—Line and bar-line charts cannot be rotated.
	· For bar and area charts, position cursor over top right-hand corner of chart, and then drag rotation icon to rotate the chart.

· For pie charts, right-click the contents area, and then click Rotate. Drag the rotation icon in the lower left-hand corner to rotate the chart.


“Pivot This Chart XE "Chart section:Pivot This Chart" ” Feature

A pivot report can be instantly created from a chart using the “Pivot This Chart” feature.

To create a pivot report from a chart:

On the Insert menu, click Pivot This Chart.

Lesson 1 Summary

In this lesson you have learned:

· There are several types of charts, including vertical and horizontal bars, vertical and horizontal stacked bars, clustered bars, pie, line, area and stacked area, and bar-line. All charts can be either 2- or 3-dimensional, except for pie charts. On the Insert menu, select New Chart, then click the down arrow on the Chart Type pull-down list (located on the Section toolbar), and select a type of chart. 

· When creating a chart, drag Request items from the catalog to the chart Outliner. Add quantifiable Request items to the Facts panel, and non-quantifiable Request items to the X- and Y-Categories panels. 

· Vertical bar charts show data changes over a period of time or illustrate comparisons among category labels. Categories are organized horizontally and values vertically. Vertical stacked bar charts show the relationship of individual category labels to the whole.

· Horizontal bar charts illustrate comparisons among individual category items. Categories are organized vertically and values horizontally. The focus is on comparing values with less emphasis on time. Stacked bar charts show the relationship of individual category labels to the whole. 

· A line chart shows trends in data at equal intervals. A bar-line chart compares and contrasts multiple, different-scaled facts in a single chart.

· A pie chart shows the proportional size of category labels to the sum of the category. It only uses one category and is useful when you want to emphasize a significant element.

· An area chart emphasizes the magnitude of change over time. By displaying the sum of the plotted values, an area chart also shows the relationship of parts to a whole.

· Each chart type can be manipulated in unique ways. One way is to double-click the content area, and then select general options in the Properties dialog box. Another way is to select a chart element (for example, a bar), right-click, and then click Properties. Chart elements have their own set of properties which can be modified.

· To instantly create a Pivot report from a chart, on the Insert menu, click Pivot This Chart.

Lesson 2: Analyzing Chart Data

Lesson Objectives

Upon completion of this lesson users will be able to:

· Drill into the underlying chart data

· Group chart report labels together

· Sort chart data various ways using the Sort Line

· Summarize chart data various ways using data functions

· Focus on specific chart data

· Hide irrelevant chart data

Drilling into Charts XE "Drilling features:Drilling into Charts" 
The Chart section has the same drill capabilities as the Pivot section:

· Drill Anywhere

· Drill Up

To drill into a chart:

1. Select one or more chart elements (bars, lines, slices, etc.).
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2.  Right-click, point to Drill Anywhere, and then click an item.

· The chart is rebuilt, displaying the selected axis label(s) broken down by the drill item.

· In the Outliner, the specified drill item is added to the appropriate panel, and the drilled item is identified with a drill-bit icon.
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To drill up:

· Right-click an Outliner item following an item with a drill bit, and then click Drill Up.

Grouping XE "Chart section:grouping"  Chart Elements

Merge chart data by grouping labels. Grouping works the same way as it did in the Pivot section.

To group axis labels in a chart:

1. Select labels in a single dimension (contiguously or discontiguously).
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2. Click the Group Items button on the Standard toolbar.

· The selected labels and their associated Facts are combined.

· The resulting label is displayed with an asterisk (*) to indicate a grouping.

3. Rename the group by double-clicking the group’s label and entering a new label name in the Set Label Item dialog box. Click the OK button to finish.

To ungroup labels in a chart:

· Select a group’s label, and then click the Group Items button on the Standard toolbar. The group’s original labels are restored.

Sorting XE "Chart section:sorting"  Charts

By default, category axis labels are sorted alphabetically, which determines the initial sort order of chart elements. Axis labels can be re-sorted based on aggregate calculations of their Facts, in ascending or descending order.

To sort labels in a chart using the Sort line:

1. Click Sort on the Section Title bar to view the Chart Sort Line.

2. Configure the Sort Line:

· In the first pulldown menu, select a label to sort.

· In the second pulldown menu, select Label to sort the labels alphabetically, or select a Fact item to be used in the aggregate calculation.

· In the third pulldown menu, select a data function (Sum, Average, Non-Null Average, Count, Null Count, Non-Null Count, Maximum, or Minimum).

· To finish, click the ascending or descending sort icon. 
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Modifying Chart Data Functions XE "Chart section:data functions" 
Request items added to the “Facts” panel of a Chart Outliner are automatically aggregated in a chart, which means the underlying data is summed, counted, averaged, etc., based on the X- and Z-Categories in the chart. The data function applied to a “Fact” can be modified if needed.

NOTE The same Request item can be used multiple times as a Fact in a chart, displaying different data functions.

To modify a data function applied to a Fact:

• Select a chart element (bar, line, area, or pie slice), right-click, point to Data Function, and then click a function (Sum, Average, Count, Max, Min, % of Grand, Non-Null Average, Null Count, or Non-Null Count).

Focusing on/Hiding Chart Labels XE "Chart section:focusing on/hiding chart labels" 
Charts can be restricted to display particular category labels using the Focus on/Hide features. Focus on and Hide features work the same way as in the Pivot section.

To focus on (or hide) chart labels:

· Select one or more chart elements to focus on (or hide from view), right-click, and then click Focus on Item (or Hide Items).

To redisplay hidden category labels in a chart:

· Select the category in the Chart Outliner, right-click, and then click Show Hidden Item.

To redisplay all hidden labels XE "Chart section:redisplaying all hidden labels" , from multiple categories:

· Right-click, and then click Show All Items. All labels in all categories are restored in the chart.

Lesson 2 Summary

In this lesson you have learned:

· By default, axis labels are sorted alphabetically, which determines the initial sort order of a chart. Use the Chart Sort Line to re-sort axis labels based on aggregate calculations of their Facts.

· “Drill Anywhere” analysis can be performed in the Chart section as well the Pivot section. Drilling enables quick investigations of specific data elements. To drill into a chart, select a chart element (bar, line, area, or pie slice), right-click, point to Drill Anywhere, and then click a Request item.

· Merge chart labels by using the Group feature. When grouped, the Facts associated with the labels are combined, creating a new label.  To group (or ungroup) labels, select labels, and then click the Group Items button in the Standard toolbar.

· Data is automatically summed in a chart. To display a different aggregate calculation, select a chart element, right-click, point to data functions, and then click a data function.

· Use the Focus on/Hide Items feature to eliminate extraneous data in a chart. The hidden data is removed from the chart, but the Request item remains in the Outliner. Hidden data can always be restored in a chart. To Focus on/Hide items in a chart, select a category label, right-click, and then click Focus on Item or Hide Items. To restore a category, click the category item in the Outliner, right-click, and then click Show All Items.

Practice Exercise: Charts Section

Objective


Become familiar with the various chart types available in the tool.  Create and manipulate the charts. 

· Open the NASA Labor Cost Voucher document from the last exercise.

· Focus on the Results section

· From the “Insert” menu and choose “New Table”

· Add the following columns to the new table by dragging them from the section catalog:

· Org

· Pay code

· Pay Cd Desc

· Total Payroll Expenses

· Detail Record Count

· Create a local limit in the table section

· Double-click any data cell in the Org column

· Click “Show Values” button

· Choose the first ten Org values and click “OK”

· From the “Insert” menu and choose “New Chart”

· Add “Total Payroll Expenses” to the Chart facts

· Add “Org” to the X-Categories

· Add “Pay Cd Desc” to the Z-stack

· From the “Format” menu, change the chart type to “Vertical Stack Bar”

· Note: you can also use the section-specific tool bar

· Set the legend on Z

· Resize the chart for easy viewing

· Select a bar and right-click to try the drill feature.

· Follow the instructor to access various chart features


NOTES:


Creating a new table allows you to create local limits for the Chart without changing the Results set and other sections dependent on the Results set (the pivots).

Chapter 6   Report Section XE "Report section" 
Upon completion of this unit users will be able to:

· Identify the following key terms:

· Free-form report

· Report Outliner

· Create simple free-form reports

· Format reports

· Add totals to report group headers

· Sort report group labels and tables

· Spotlight exceptional report values

· Modify report data functions

· Add graphics and text

· Embed pivot reports and charts

· Prepare reports for printing by:

· Adjusting page margins

· Editing headers and footers

· Setting page numbering

Lesson 1: Creating Free-Form Reports

Lesson Objectives

Upon completion of this lesson users will be able to:

· Identify the following key terms:

· Free-form report

· Report Outliner

· Create simple free-form reports

· Format reports

· Add totals to report group headers

· Sort report group labels and tables

· Spotlight exceptional report values

· Modify report data functions

· Add graphics and text

· Embed pivot reports and charts

About the Report Section

The Report section gives users the ability to create free-form report styles.  With a free-form structure, reports can easily be laid out to exact pixel specification. The Report section has flexible page sizing and matrix, including a page view to get an accurate representation of the report layout. Extensive drawing tools are available and background pictures can be incorporated.

Report Elements XE "Report elements"  XE "Report section:report elements" 
Reports can consist of elements such as tables, report group headers, graphics, and pivot reports. Each element in a report has a set of properties that can be manipulated. Elements are stored in containers which makes it easy to select them. Exclusive to the Report section is the ability to include pivot reports, charts, and table reports.

In the Report section, reports are created by dragging items from the Catalog pane to the report Outliner XE "Report section:report Outliner" . The Outliner consists of the Group Outliner and Table Outliner. The Table Outliner is divided into the Table Dimensions and Table Facts panes. Table facts are summarized at the table dimension levels, and broken down by report groups. Below is an illustration of the report Outliner.
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Creating Free-Form Reports

To create a free-form report XE "Report section:free-form reports" :

1. On the Insert menu, click New Report.

2. Click Groups and Table on the Section Title bar to view all panes in the report Outliner.

3. Add Request items from the Catalog to the Groups or Table Outliner.

· Drag quantifiable items to the Table Facts pane. Totals are automatically generated in the report body.

· Drag non-quantifiable items to the Table Dimensions pane to itemize the facts.

· Drag non-quantifiable items to the Report Groups pane to create separate tables for each label in a report group.

Use the table below to learn how to modify a report XE "Report section:formatting reports" .

	Report Modification
	How To

	Remove a report group, table dimension, or table fact
	Click an Outliner item, right-click, and then click Remove.

	Change the layout of report groups, table dimensions, and table facts
	· Drag a report group or table dimension to a new position in the Outliner.

or

· Reorder table facts within the Table Facts panel of the Table Outliner.

or

· Drag table dimensions and table facts manually in the report’s body.

	Show/Hide a table fact’s total
	Click a table fact in a report, right-click, and then click Show Column Total. A check mark indicates the total is visible. The Grand Total button on the Standard toolbar can also be used.

	Resize a column in a table
	Select a column in a table. Position the cursor over the column’s margin, and then double-click to Auto-Size or drag the margin left or right.


	Resize a row in a table
	Click the left side of the first column in a table to highlight the row.
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Position the cursor over the bottom row margin, and then drag the margin up or down. All rows in the table are resized.

	Resize a report group header
	Click in a report group header in the report. Position the cursor over the row’s margin, and then double-click to Auto-Size or drag the margin up or down.

	Show/Hide column titles in a table
	Select any column in a table, right- click, and then click Show Column Titles. A check mark indicates the column titles are visible.

Note—this feature hides all column titles in a table

	Repeat group headers if content spans multiple pages
	Click in a group header (not on a group header label), right-click, and then click Repeat Header.

	Resize an object’s container
	Position the cursor over an object (for example, a table or pivot report). When it changes to a 4-directional cursor, click the object. Drag the container’s handles to resize the container.

	Suppress duplicate column values in a

table
	Select a column, right-click, and then click Suppress Duplicates.




Properties

Report elements (labels, columns, pictures, etc.) consist of a standard set of properties. These properties can be easily modified.  Double-click on a column to reach the formatting options.  Properties include:

· Font: Change the font type, text style (Regular, Italic, Bold, Bold Italic), font size, effect (Underline, Overline, Double-Overline), and text color.
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· Number: Apply a number format (Number, Currency, Percentage, Date, Time, Custom).
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· Alignment: Modify the horizontal alignment (left, center, right), vertical alignment (top, middle, bottom), rotation (Horizontal, Vertical, Vertical Rotated Up, Vertical Rotated Down), and text control (Wrap Text setting).
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The next set of properties can be reached from the Format button on the Standard Toolbar, under the Border and Background button.

· Border and Background: Modify the border (line Color, Width, and Style) and background (Color and Pattern).
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· Picture: Specify the file name and location of a bitmap, percent scale (Height and Width), and picture effect (None, Stretch, Clip, Tile).
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Gridlines can be reached from the Format button on the Standard Toolbar.

· Gridlines: Modify the horizontal and vertical line styles in a table.
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Use the table below to quickly learn each report object’s modifiable properties.

	Object
	Properties
	How To Find the Properties

	Group Header Label (TextLabel)
	Number, Font, Alignment, Border and Background
	Double-click a report group header label.
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	TextLabel
	Font, Alignment, Border and

Background
	Position the cursor over the text “TextLabel”.  A 4-directional arrow appears.  Click, and the text label’s border handles appear.  Right-click, and then click Properties.

	Table
	Border and Background, Gridlines, Font, Number,

Alignment
	Double-click a table. This only works if there is one column in the table.

	Column
	Font, Number, Alignment
	Double-click a column in a table.

	Graphic Shape (Line, Hz Line, Vt Line, Rectangle,

Round Rectangle, Oval)
	Border and Background
	Double-click a graphic shape in a report.

	Picture
	Alignment, Picture
	Double-click a picture in a report.




Report Page Setup XE "Report section:report page setup" 
To specify margin sizes and column settings:

1. On the Report menu, click Report Page Setup. (Alternatively, double-click the ruler, if visible.)
2. Configure the Report Page Setup dialog box:

· Set page size in the Page Size XE "Report section:margin sizes"  tab (use printer dimensions, custom dimensions)
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· set margin sizes in the Margins XE "Report section:margin sizes"  tab (top, bottom, left, and right)
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· specify the number of columns XE "Report section:number of columns on a page" 

 XE "Report section:column settings"  on a page and the default column width and spacing in the Columns tab
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Inserting Page Breaks

Page breaks can be inserted before/after a report body or before/after a

report group label.

To insert a page break XE "Report section:inserting page breaks" :

· Select a report group header (be careful not to click the report group label), then from the Insert menu select either Page Break After or Page Break Before. A page break is inserted.
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To remove a page break XE "Report section:removing a page break" :

· Select a report group header with a page break applied, go to the Insert menu and select the item with the check mark (either Page Break After or Page Break Before).  The page break is removed.
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Adding Totals XE "Report section:adding totals"  to Report Group Headers

By default, totals are automatically generated for table facts. These totals

can be displayed or hidden. The formulas behind these totals can be used

to calculate totals for any report group.

To calculate a total in a report group header:

· Drag an item from the Catalog pane to a report group header. 
Sorting Reports XE "Report section:sorting" 
Report groups and table columns can be sorted alpha-numerically or based on formulas.

Sorting Report Groups XE "Report section:sorting groups" 
To sort a report group:

1. Click Sort on the Section Title bar to view the report Sort line.

2. Drag a report group label from the contents pane to the Sort line.
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3. Configure the Sort line.

· Reorder the Sort items to determine the nested sort order.

· Double-click Sort items to toggle between ascending and descending sort orders.
Sorting Tables XE "Report section:sorting tables" 
To sort a table:

· Select a table column, and then drag it to the Sort line. Multiple table columns can be added to the Sort line to create a nested sort.
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Sorting by Formula XE "Report section:sorting by formula" 
To sort a report group based on a formula:

· In a report group header, select a total value or calculated field, and then drag it to the Sort line.
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Spotlighting XE "Report section:spotlighting" 
Use the Spotlighter in the Report section to spotlight exceptional values in a table.

To spotlight exception values:

1. Select a column in a table.

2. On the Format menu, click Spotlighter.

3. In the Spotlighter window, build a conditional format - 

· Choose a comparison operator from the pull-down menu
· Enter a comparison value in the edit field
· Choose an exception text format by clicking the font style buttons and color boxes
· Add formatting styles and colors to spotlight the data. The sample text in the dialog box previews the spotlighter formatting
4. Click the green check mark button to apply the conditions.

5. View the spotlighted values in the report.

NOTE Multiple conditions can be applied to a column.

To modify Spotlighter formats:

1. Select a column that contains a Spotlighter format.

2. On the Format menu, click Spotlighter. The Spotlighter window appears, displaying the formats applied to the column in the format scroll box.

3. In the Spotlighter window, double-click the spotlighter format (to be modified) in the scroll box. All conditional formats applied to the column are captured to the editor.

4. Make any desired changes to the condition or format, and then click the green check mark button to reapply the modified spotlighter format. The modified format is reapplied to the column.

To copy Spotlighter formats:

1. Select a column in a report that contains a Spotlighter format.

2. In the Spotlighter window, select the spotlight formats (to be copied) in the scroll box, and then click the Capture button. The spotlighter format is captured to the editor.

3. Select a new column in a report as the target area to apply the copied Spotlighter formats. The target area can be in the same report or a different one.

4. In the Spotlighter window, click the Restore button. The captured formats are applied to the selected report element.

To remove a Spotlight from a selected Fact column:

1. Select a spotlighted column.

2. In the Spotlighter window, select a format (to remove) in the scrollbox, and then click the Remove button on the Standard toolbar. The Spotlighter format is removed.

Data Functions

Table facts are automatically summarized in a report based on the table dimensions and report groups; however, the data can be aggregated differently by changing the data function. Also, an item from the Catalog pane can be added multiple times to the Table Facts pane in the Outliner, each time calculated using a different data function.

To change the data function XE "Report section:changing the data function"  applied to a table fact:

1. Select a table fact in a report.

2. Right-click, point to Data Function, and then click a data function (Column Name, Sum, Count, Average, Minimum, Maximum, % of Category, Null Count, Non Null Count, Non Null Average).

Adding Graphics

Shapes

Lines, horizontal lines, vertical lines, rectangles, round rectangles, and ovals are available.

To add a graphic XE "Report section:adding graphics"  to a report:

1. Drag a graphic item from the Graphics folder in the Catalog pane to the content pane.
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2. Modify the graphic.

· To move a graphic, drag it to a different position.

· To resize a graphic, select it, and then drag one of its handles.

· Double-click a graphic to modify its border and background.

Text

Add text to a report by using the Text Label item.

To add text to a report XE "Report section:adding text" :

1. Drag the Text Label item from the Graphics folder in the Catalog to the content pane.

2. Click TextLabel.
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3. Enter text.

4. Modify the text label’s properties.

· Position the cursor under the text (the cursor changes to a 4-directional arrow), and then click.
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· Once the text label’s container handle’s appear, right-click, and then click Properties.

· Select options in the Number, Font, Alignment, and Border and Background tabs, and then click the OK button.

To append text to a report group label XE "Report section:appending text to group label" :

1. Select a report group label.

2. In the Expression line, enter text in double quotes before or after the equation, enter a plus sign “+” to concatenate text, and then click the green check mark button.
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Pictures

Bitmap pictures can be added to a report.

To add a picture to a report XE "Report section:adding pictures" :

1. Drag the Picture item from the Graphics folder in the Catalog to the content pane.

2. In the Select Image dialog box, browse and select a bitmap file, and then click the OK button. The picture is added to the report.

3. Modify the picture’s properties.

· To move the picture, drag it to a different position.

· To resize the picture, select it, and then drag one of its handles.

· Double-click the picture to modify its properties.

To add a background picture to a report:

1. Right-click on the contents pane (careful to not select anything), and then click Properties.

2. In the Picture tab of the Properties dialog box, browse and select a bitmap for the background picture, and then click the OK button. The picture is added to the report for each report group header or body.

Embedding Pivot Reports and Charts XE "Report section:embed pivots and charts" 
One of the most powerful features of Report section is the ability to combine pivot reports and charts in a single report. Pivot reports and charts are inserted into report group headers and bodies intelligently, meaning they reflect only the relevant data for the report level in which they are inserted. This type of report is referred to as a Smart Report XE "Smart Report" .

 To add a pivot report or chart to a report:

Drag a pivot report or chart from the Query folder in the Catalog pane to a report group header or body.

Lesson 1 Summary

In this lesson you learned:

· Use the Report section to create free-form report styles.

· To create a report, drag Results columns from the Catalog pane to the Report Outliner.

· To change the layout of a report, drag Outliner items to new locations within the Outliner. Table dimensions and facts can also be manually dragged to new locations in the content pane.

· Reports can consist of report group labels, tables, graphical shapes, text labels, pictures, and embedded pivot and chart reports. Each report element consists of a set of properties. These properties can be modified. To access the Properties dialog box for most report elements, simply double-click it in the report.

· Totals displayed in tables can be hidden or displayed. To add a total to a report group header, drag a Results column from the Catalog pane to a report group header.

· Use the Sort line to sort report group labels and tables. Drag report group labels, table columns, and fields to the Sort line to determine the sort criteria. Double-click Sort items to toggle between ascending and descending sort orders.

· The Spotlighter is used to highlight exceptional values in a report. To spotlight values, select a column, define the criteria to spotlight in the Spotlighter window, and then click the green check mark button in the Spotlighter window.

· In the Report section, table facts are automatically summed. To change the aggregate calculation, select a table column in a report, right-click, point to Data Function, and then click a data function. A Results column can be added to the Report Outliner several times in order to display different calculations.

· To add a graphical shape, text, or picture to a report, drag the object from the Catalog pane to a report group header or body. Pictures must be in bitmap format.

· Pivot reports and charts can be embedded in a report. When added to a report group header, a pivot report or chart is filtered to display only the relevant data for the corresponding label. 

· Page breaks can be inserted before/after a report group label.

Practice Exercise: Reports Section

Objective


Using the Report Section can be initially daunting, but once mastered proves to be one of Brio’s most powerful features.  Here you will learn the basics of how the Report Section does what it does and when to use it’s more advanced features.

· Open the “NASA Labor Cost Voucher” document you’ve been working with or open a new copy and process the query

· From the “Insert” menu choose “New Report”

· From the “Report” menu choose “Section Boundaries”

· If the Groups and Tables outliners are not open, open them with the toggles on the Section Title Bar

· Drag “Pay Code” from the catalog to the Table Dimensions outliner

· Drag “Pay Code Hours” and “Pay Code Amount” from the catalog to the Table Facts area.

· Resize the table to fit the data and format appropriately

· HINT: Double-click the right margin of the column you want to auto size

· HINT: Number formats are available via the hot menu

· Add “Org” to the Groups outliner at the Group1 level

· From the “Report” menu choose “Headers and Footers > Report Header”

· Drag “Pay Period” from the catalog to the report header

· Format with no commas

· From the “Graphics” folder in the catalog drag “Text Label” to the report header

· Click inside the dummy text and re-type “Report for pay period”

· Add the Report Name from the “Fields” folder to the page header

· Re-Title the report as “Pay Code Hours Summary”

· HINT: you need to rename the Report Section

· Line up the text and the pay period number

· Use the alignment tools and text-flush features get the alignment straight

· Set the font size and format the same for both fields

· Drop a new text label into the body of the report

· Re-type it to read “Totals”

· Place it in the last data cell of the Pay Code column

· Use the “Spring to” feature to make the word float (instructor will demo)

· Return to the Results Section and “Insert > New Chart”

· Drag “Pay Code Hours” to the chart facts

· Drag “Pay Code” to the X-Categories

· Remove the axis labels and chart title

· Reduce the font sizes of all the remaining chart text to 7 point

· Re-size the chart to fill the available area

· Return to the Report Section

· Drag the chart from the catalog (lower half) to the right of the table in the Report body

· Re-size the chart in the Report body, allowing enough room to see the labels clearly

· Sort the table to match the chart bars

· Open the “Sort” tool with the toggle if necessary

· Click on the table

· Click a data cell in the dimension column (“Pay Code”) and drag to the sort tool

· Create a footer for the page that includes

· Time & date

· Page number x of y

· Privacy act notice

· Bonus

· Create a cover sheet for the report using the “Report Header” feature

· Add Graphics and Fields you think appropriate


NOTES:


Grouping is a very useful and powerful feature of the Report Section.  It will aggregate other sections (Pivots, Charts) along the group dimension.

Lesson 2: Preparing Reports for Printing XE "Report sections:preparing for printing" 
Upon completion of this unit users will be able to:

· Adjust page margins

· Edit headers and footers

· Set page numbering

“Finishing Touches”

Once a report is created, add the finishing touches by adjusting page margins, adding headers and footers, and setting page numbers in Print Preview mode. The Report section does not have a Print Preview mode.  Margins, headers, footers, and page numbering can be done in regular mode.

Page Margins XE "Report section:page margins" 

 XE "Report section:adjusting page margins" 
To adjust page margins:

1. On the Report menu, click Page Margins.  Dotted lines representing page margins appear in the content pane.

2. Position the cursor over one of the dotted lines.  The cursor becomes a 2-directional arrow.
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3. Drag the margin to a desired position.

4. Alternatively, specify the margins exactly.  On the Report menu, click Report Setup. In the Margins tab of the Report Page Setup dialog box, specify the exact margin sizes.

Headers and Footers XE "Headers and Footers"  XE "Report section:headers and footers" 
In a Report section, there is one page header and one page footer. There is also one report header and one report footer. The report header only appears on the first page and the report footer only appear on the last page.

To edit a report header or footer XE "Report section:editing report header or footer" :

1. On the Report menu, point to Headers and Footers, and then click Report Header, Report Footer, or Show Both. The content pane displays the report header or report footer (or both).

2. Add graphics and fields to a report header or footer.

· From the Graphics folder in the Catalog pane, drag a graphic to a report header or footer. The following graphics can be added:

· Line

· Hz Line (horizontal line)

· Vt Line (vertical line)

· Rectangle

· Round Rectangle

· Oval

· Text Label

· Picture

· From the Fields folder in the Catalog pane, drag a field to a report header or footer. The following fields can be added:

· Field (used for calculations)

· Query Limit

· Result Limit

· Page Number

· Number of Pages

· Page X of Y

· Last Saved

· Last Printed

· Date

· Time

· Date & Time

· Date Now

· Time Now

· Date and Time Now

· File Name

· Path Name

· Report Name

Page Numbering XE "Report section:page numbering" 
To set page numbering in the Report section, edit the expression for the Page Number field.

To set page numbering XE "Report section:setting page numbering"  in a Report section:

· Select a page number field in a report, and then modify the expression in the Expression line.

Lesson 2 Summary

In this lesson you learned:

· Print Preview mode is disabled in the Report section. Adjusting report margins, adding page headers and footers, adding report headers and footers, and setting page numbering is done in regular mode.

· To create a page/report header or footer in a Report section, display a header or footer, and then drag items from the Graphics or Fields folder in the Catalog pane to a header or footer.

· To alter the starting page number in a Report section, drag the Page Number item from the Fields folder in the Catalog pane to the content pane, and then modify the expression in the Expression line.

Appendix A  -  Glossary of Terms

Adaptive Report Level An Adaptive Report level defines how a user can interact with a BrioQuery document. Levels include View, View and Process, Analyze, Analyze and Process, and Query and Analyze. When a document is registered to the OnDemand Server, groups of users are granted access to it, with specific Adaptive Report level privileges.

Auto-Join An administrator can configure a connection file to cause joins to occur automatically for users via the Auto-Join feature. Auto-join can be configured one of three ways: Best Guess, Custom, and Server-Defined.

Auto-Process Auto-Process is the automatic processing of a query.

Brio.Insight Brio.Insight is a Brio application (available as a plug-in and stand- alone application) that enables users to create queries, analyze data, and create reports over the Web.

Brio.Quickview Brio.QuickView is a Brio application (available as a plug-in and stand-alone application) that enables users to view and process BrioQuery documents over the Web.

BrioQuery Explorer BrioQuery Explorer is a Brio client/server application that enables users to create queries, analyze data, and build reports. Users can access database tables directly in order to create data models, as well as access pre-built BrioQuery documents stored in a Repository.

BrioQuery Navigator BrioQuery Navigator is a Brio client/server application that enables users to create queries, analyze data, and build reports. Users access pre-built data models, queries, and reports stored in a Repository or on a file server.

Broadcast Server Broadcast Server is a Brio application, residing on a server, that enables users to schedule queries to process on a regular basis or during convenient off-hours, and then distribute the results across a network or to an intranet.

Business Intelligence Organizations utilize information from various operational systems, data marts and/or data warehouses in order to improve business processes, enhance customer service, accelerate sales, and increase profitability.

Chart Report Charts are fully interactive, three-dimensional views of data.  Users create charts to convert raw data into eloquent, visual information.

Chart Section With a varied selection of chart types, and a complete arsenal of OLAP tools like group and drill-down, the Chart section is built to support simultaneous graphic reporting and ad-hoc analysis.

Client/Server Client/Server refers to a network architecture in which each computer or process on the network is either a client or a server.

Computed Item Computed items are new data items that are computed locally by the Brio client application or on the database. Computed items are utilized like normal data items, and can be included in reports or re-used to compute other data.

Connection File A connection file, also known as an OCE (Open Catalog Extension), is a small file containing all of the software and network specifications needed to connect to a database. Connection files have a *.oce file extension.

Cross Join A cross join creates a query where none of the tables is joined.

Every row in one table is joined to every row in another table.

Data Function A data function is an aggregate calculation that produces a single value based on a set of values. Examples of data functions include sum, average, and count.

Data Model A data model is a semantic layer in a BrioQuery document that represents a subset of database tables, used to create queries. Data Models are displayed in the Query section of a document.

Database Function A database function is a pre-defined formula in a database.

Datatype Datatype refers to the type of data stored in a specific column in a database. For example, data can be stored as a numeric datatype.

Date Group The Date Groups feature in the Results and Table sections separates a column of date datatype into Year, Quarter, and Month columns. The display format for the new Month column is automatically set to “mmm” so that the month names sort chronologically (as opposed to alphabetically) in the report sections. Quarters are based on the calendar year, beginning January 1st.

Detail View Detail view displays a topic as a database table. When Detail view is selected by the user, the database returns ten sample rows from the associated table. Each topic item is displayed as a database field.  Detail view enables users to browse a sample of the raw data, which can be is useful if they are unfamiliar with the data model or the underlying data. Users cannot view a meta topic in Detail view.

Dimension Table A dimension table consists of numerous attributes about a specific business process. Each row in a dimension table is unique.

Drill Anywhere The Drill Anywhere feature enables a user to drill into and add items to a pivot report that are resident in the Results section, without having to return to the Query section or try to locate the item in the Catalog pane. Drill anywhere items are broken out as new pivot label items.

Drill to Detail Drill to Detail enables a user to retrieve items from a data model that are not in the Results section, without having to rerun the original query. This feature provides the ability to interactively query the database and filter the data that is returned. Drill to Detail sets a limit on the query based on the user’s selection and adds the returned value as a new pivot label item automatically.

Expression Line In the Report section, the Expression line displays the JavaScript syntax for each item displayed in a report. Use this line to build equations. For ease of use, it can be undocked and resized.

Extranet An extranet refers to an intranet that is partially accessible to authorized outsiders. Extranets are secured by user names and passwords.

Fact Table A fact table is created to store business activity measures.  Most fact tables are extremely large. Each row in a fact table contains numeric measures (fully additive measures, non-additive measures, and/or semi-additive measures) and foreign keys to each dimension table.

File Server XE "File Server"  A file server is a computer and storage device dedicated to storing files.

Foreign Key A foreign key is a database column or set of columns included in the definition of a referential integrity constraint.

Fully Additive Measure Fully additive measures are attributes in a table that can have their values added together across any dimension.

Grain The level of detail at which measures in a table are recorded is referred to as the grain.

Grouping Column The Grouping Columns feature in the Results and Table sections creates a new column in a dataset by grouping data from an already existing column. Grouping columns consolidate non-numeric data values into more general group values and map the group values to a new column in the dataset.

Icon View Icon View shrinks a selected topic to an icon in the Content pane. The topic remains part of the data model, but is deactivated and cannot be accessed by the query. Associated items are removed from the Request line when a topic is iconized, and the topic is not recognized as joined to other topics. Icon view is helpful in restricting the use of server time when a topic is infrequently used, and it does not have to be active at all times.

Indexes Indexes are created in a database to increase the performance of data retrieval. Just as book indexes help to locate specific information faster, database indexes provide a faster access path to table data.  Indexes are created on one or more columns of a table.

Integrity Constraints Database administrators create integrity constraints on tables to guarantee that the data adheres to certain business rules.  Integrity constraints are defined with a table and are stored as part of a table's definition, centrally in the database's data dictionary, so that all database applications adhere to the same set of rules.

Internal Function Internal functions are built-in formulas, defined in the Brio application.

Internet The Internet is a global network connecting millions of computers. Unlike online services, which are centrally controlled, the Internet is decentralized by design. Each Internet computer, called a host, is independent.

Intranet An intranet is a network belonging to an organization, usually a corporation, accessible only by the organization's members, employees, or others with authorization. An intranet's Web site looks and acts just like any

other Web site, but the firewall surrounding an intranet fends off unauthorized access.

Item An item is a visual representation of a database column and is a member of a topic in the Query section. Items are used to create queries and reports.

JavaScript JavaScript is a World Wide Web scripting language that is understood by a web browser when it is between <SCRIPT>...</SCRIPT> tags.

Job Repository A job repository is a set of database tables which store a queue of scheduled jobs. There can be multiple job repositories in an organization. Job repositories are polled periodically by a Broadcast Server, which downloads and processes jobs when they are due to run.

Join A join is a link between two topics, typically indicating the presence of the same item, or very similar items, within each topic. The visual joins seen in a data model reflect join relationships established in the underlying database.

Join Path A join path is a pre-determined join configuration for a data model. Administrators create join paths so that users simply need to select the type of data model needed, in a user-friendly prompt, upon processing a query. Join paths ensure that the correct tables in a complex data model are being used in a query.

Linked Data Model The term linked data model refers to documents that are linked to a master copy in a Repository. When changes are made to the master, users are automatically updated with the changes when they connect their duplicate copy to the database.

Local Limit A local limit is a temporary filter set on a dataset which enables users to focus on specific data in the reports.

Locked Data Model Data Models that are locked cannot be modified by a user.

Master Data Model A document can contain a master data model (or multiple master data models), which enables a user to base multiple queries on the same data model within a document. When using a master data model, the text “Locked Data Model” appears in the content pane of the Query section. This means that the data model is linked to the master data model displayed in the DataModel section, which may be hidden by an administrator.

Multidimensional Database Multidimensional databases store data in a format often referred to as a cube, where measures are pre-calculated.

Non-Additive Measure Non-additive measures are attributes in a table that cannot be added across any dimension, such as a percentage value (for example, margin rate).

Null value A null value is absent of data.

OnDemand Server OnDemand Server is a Brio server application that enables users to view and select from a list of available documents over the Web, as well as to build and process new queries.

Outliners Outliners are drag-and-drop templates used in the Pivot, Chart, and OLAPQuery, and Report sections. Each Outliner panel corresponds to a specific layout element of the report. When an item is dragged to an Outliner panel, the item assumes the layout attributes of the respective report element. Data appears simultaneously in the Contents pane with the appropriate formatting.

Pivot Section The Pivot section is used to create crosstab reports and analyze data.

Pivot Dimension A pivot dimension is a row or column of labels and corresponds to an item in the Catalog pane.

Pivot Report Pivot reports are analytical tools that resemble spreadsheets or crosstab reports. A Pivot report overlays a dynamic datacube, which allows data to be sliced and diced for ad-hoc, interactive, and multidimensional analysis.

Plug-in Plug-ins add seamless functionality to a Web browser, enabling the browser to open a plug-in’s particular file type. A plug-in is a special application file placed in a browser’s Plug-in directory.

Pre-defined Drill Paths A predefined drill down path enables a user to drill directly to the next level of detail, as defined in the data model.

Primary Key A primary key is a database column or set of columns included in the definition of a table's PRIMARY KEY constraint. A primary key's values uniquely identify the rows in a table. Only one primary key is defined per table.

Query A query is a set of database instructions to return an answer set to a specific question. Each row returned in the Results section of a document is an answer to the question posed in the Query section.

Relational Database Relational databases, used for decision support, are usually designed using a star schema approach with fact and dimension tables.

Report Section The Report section is a dynamic, analytical report writer, providing users with complex report layouts and easy to use report building tools. Pivot reports, table reports, and charts can be embedded in a report.  The report structure is divided into group headers and body areas, with each body area containing a table of data. Tables are created with dimension columns and fact columns. These tables are elastic structures.  Multiple tables can be ported into each band, each originating from the same or different result sets.

Repository refers to a centralized storage location on a database, which stores BrioQuery documents containing data models, queries, and/or reports. A Repository categorizes each document under one of the following titles: Data Model, Standard Query, and Standard Query with Reports.

Results Section The Results Section is a section in a BrioQuery document that contains the dataset derived from a query. Data is massaged in the Results section for use in the report sections.

Semi-Additive Measure Semi-additive measures are attributes in a table that can be summarized across some dimensions, but not all.

Simple Join A simple join between topic items creates a query that retrieves rows where the values in joined columns match.

Snapshot A read-only table snapshot is a local copy of table data that originates from one or more remote master tables.

Stand-alone Application A stand-alone application is any application commonly used to open a particular file type. The application is associated with a browser and assists it by automatically opening a file type which the browser cannot open on its own. A stand-alone application is independent of a browser.

Standard Query A Standard Query is a type of Repository document that contains pre-built queries (that is, pre-built Query sections) from which users can process and create new reports.

Standard Query with Reports A Repository document categorized as a Standard Query with Reports contains pre-built queries and reports which users can view and manipulate.

Star Schema In a star schema, a database table is coined as either a dimension or a fact table.

Structure View Structure view displays a topic as a list of component items. It allows users to see and quickly select individual data items, which is convenient when they are familiar with the data model and know how they want to build their query. Structure view is the default view setting.

Surface Values Use the surface values setting in the Pivot section to base aggregate calculations on the values in the report, rather than the values in the Results section.

Synonym A synonym is an alias for a database table or view. It is a direct reference to a table view.

Table A table is the basic unit of data storage in a database. Database tables hold all of the user-accessible data. Table data is stored in rows and columns.

Table Catalog The Table Catalog displays tables, views, and synonyms to which users have access. Users drag tables from the Table Catalog to the Content pane to create data models in the Query section.

Table Section The Table section is used to create tabular-style reports. It is identical in functionality to the Results section, including the grain level (table reports are not aggregated). Other reports can stem from a table section.

Topic A topic is a visual representation of a database table in the Content pane. Topics are part of data models displayed in the Query section and can contain one or more items.

Underlying Values Underlying values is another name for Results values.  When Use Surface Values is disabled in a Pivot section, aggregate calculations are based on values in the Results section.

Variable Limits Queries can contain variable limits that prompt users to enter or select limit values before the queries are processed on the database.

View A view is a custom-tailored presentation of the data in one or more database tables. Views do not actually contain or store data; rather, they derive their data from the tables on which they are based, referred to as the base tables of the views.

World Wide Web (WWW) The World Wide Web is a system of Internet servers that support specially formatted documents. The documents are formatted in a language called HTML (HyperText Markup Language) that supports links to other documents, as well as graphics, audio, and video files.

Zero Administration Brio Web applications (Brio.Insight and Brio.Quickview) can be automatically installed/updated, without the help of an administrator, when a user logs on to the OnDemand Server. This is referred to as Zero Administration.

Appendix B  -  Functions and Operators

This appendix contains information about the following:

· Database-specific functions

· Internal Brio client functions

· Operators in computed dialog boxes

Database-specific Functions XE "Functions" 
Absolute Value - Returns the absolute value of column data.  Numeric

Add Months - Returns a date advanced by a specified number of months, n.  Date

Ceiling - Returns the smallest integer greater than or equal to column data.  Numeric

Character to Date - Returns a character string in Date format.  Date

Concat - Returns column data concatenated with a specified character string. Text

Current Date - Returns the current date and time.Date

Date to Character - Returns a date as a character string.Text

Decode - Compares column data to a defined expression, and returns a specified result if there is a match, or a specified default if there is no match.  Numeric, Text, Date

Floor - Returns the largest integer equal to or less than column data.  Numeric

Initial Caps - Returns the first letter of each word of column data capitalized, the remainder in lower case.  Text

Last Day - Returns date of the last day of the month containing a date.  Date

Left Pad - Returns column data left-padded to a specified total length, n, using the sequenced characters of a specified string.  Text

Left Trim - Left-trims column data up to the first character not included in a specified character set.  Text

Length - Returns the length of a character string.  Text to Numeric.

Lower Case - Returns column data in lower case.  Text
Months Between - Returns fractional value of difference in months between  column data and a specified date.  Date to Numeric

Next Weekday - Returns date of the next occurrence of a specified weekday after a date.  Date

Null Replacement - If column data is null, returns specified substitute data.  Numeric, Text, Date

Power - Returns column data raised to a specified exponential power, n.  Numeric

Right Pad - Returns column data right-padded to a specified total length, n, using the sequenced characters of a specified string.  Text

Right Trim - Right-trims column data up to the first character not included in a specified character set.  Text

Round - Returns column data rounded to a specified integer place, n.  Numeric

Sign - Returns indicator of -1, 0, or 1 if column data is variously negative, 0, or positive.  Numeric

Square Root - Returns square root of column data.  Numeric

Substring - Returns a portion of column data of specified character length, n, beginning with a specified character, m.  Text

Truncate - Returns column data truncated at a specified integer place, n.  Numeric

Upper Case - Returns column data in upper case.  Text

User - Returns logon name of the current user.  TextDECODE

Internal Brio Client Functions

Brio clients support a large number of conditional, date, math, and string functions, available in the report sections. In the tables below, the variables n, s, d and exp (and val) represent data items and columns (State, Amount Sold) or actual values (“NY”, 6000) as arguments to scalar functions, and indicate number, string, date or variable types, respectively.

The variable c indicates that only a data item reference may be used, and not a constant value. If constant values are substituted for data items, dates and text strings must be enclosed in single quotes. Examples in the table below use a mixture of constants and data items, which are generally interchangeable.

Conditional Functions

Decode (c,exp,val,exp,val...def) Compares value of item c to one or more expressions exp, and returns the value val matched to each expression,

or a default def.  Example: decode (region, “South America”, “Priority 1”, “Asia”, “Priority 2”, “Europe”, “Priority 3”, null) substitutes priority values for the specified regions and leaves other regions null.

Nvl (c,exp1,exp2) Returns exp2 if null, and exp1 otherwise.  Example: nvl (Phone_No,Phone_No, “Not Recorded”) returns “Not Recorded” when no telephone number is on record for a customer.

AddMonths(d,n) Returns date d offset by a number of months, n.  Example:  add_months (‘5/13/99’,4) = 9/13/99

DayOfMonth(d) Returns the numeric day-of-the-month value for each value of d.

Example: day_of_month (11/02/99 09:46:00 AM) = 2

LastDay(d) Returns date of the last day of the month containing date d.

Example: last_day (‘12/6/99’) = 12/31/99

MonthsBetween(d1,d2) Returns the fractional value of difference in months between dates d1 and d2.  Example: months_ between (‘12/5/99’, ’5/6/99’) = 6.9677

NextDay(d,s) Returns date of the first weekday s after column date d. The default value for s adds one day to d.  Example: next_day (“12/16/97”, “Monday”) = 12/22/99

Sysdate(c) Returns the current system date and time for each record in item c. Any item can be used, but an item must be included as a record base.

Example: sysdate (Order_No) = 2/11/96 19:54:36

Tochar(n) Returns number n or date d as a text string. This function does not change the data, but rather the item data type.  The results cannot be computed

mathematically.  Example: to_char (50) = 50

ToDate(s) Returns date type in place of date-string s. This function does not change the data, but rather the item data type. The results can be computed

mathematically.  Example: to_date (“10/12/96”) = 10/12/96

ToMonth(d) Returns a numeric month value for each value of d. You can change the value to display as a month string (e.g., (“Nov”) by adding and applying a mmm date format.  Example: to_month (11/2/99 09:46:00 AM) = 11/15/99 ~ Nov

ToQtr(d) Returns a string quarter value for each value of d.  Example: to_qtr (11/02/99 09:46:00 AM) = Q3

ToYear(d) Returns the integer year for each value of d. You can convert the year to display without commas by applying the 0 numeric format.  Example: to_year (11/02/99 09:46:00 AM) = 1,999 ~ 1999

Math Functions

Abs(n) Returns the absolute value of number n.  Example: abs(-3) = 3

Atn(n) Returns arc tangent of number n radians.  Example: atn(1) = .7854

Ceil(n) Returns the smallest integer value greater than or equal to number n.  Example: ceil(5.6) = 6

Cos(n) Returns cosine of number n radians.  Example: cos(0.5) = .8778

Cosh(n) Returns hyperbolic cosine of number n radians.  Example: cosh(0.5) = 1.1276

Count(c) Returns the number of row values in c (including nulls).  Example: count (units) = tally of rows in units

Exp(n) Returns e (2.718) raised to exponential power n.  Example: exp(4) = 54.598

Max(a,b) Returns the larger of items a and b for each new value.  Example: max(7, 10) = 10

Min(a,b) Returns the smaller of items a and b for each new value.  Example: min(7, 10) = 7

Mod(n,m) Returns the integer remainder of number n divided by number m. If m is larger, the default value is n.  Example: mod (6,2) = 0

Power(n,m) Returns number n raised to exponential power m.  Example: power(10,5) = 100,000

Round(n,m) Returns number n rounded to m decimal places. The default value for m is 0.  Example: round (5.6178,2) = 5.62

Sign(n) Returns indicator of -1, 0, or 1 if number n is variously negative, 0, or positive.  Example: sign(-4) = -1

Sin(n) Returns sine of number n radians.  Example: sin(86) = -0.923

Sinh(n) Returns hyperbolic sine of number n radians.  Example: sinh(.5) = .5211

Sqrt(n) Returns square root of number n.  Example: sqrt(81) = 9

Tan(n) Returns tangent of number n radians.  Example: tan(30) = -6.405

Tanh(n) Returns hyperbolic tangent of number n radians.  Example: tanh (45) = 1.6198

Trunc(n,m) Returns number n truncated to number m decimal places. The default value for m is 0.  Example: trunc(56.0379,2) = 56.03

Numeric Functions

Avg(numbers, break_col, break_value)   Returns the average (arithmetic mean) of values in a number column. The Avg includes NULL values when calculating the arithmetic mean.

AvgNonNull(numbers, break_col, break_values)  Returns the average (arithmetic mean) of values in a number column, excluding null values.

chr(n)  Returns string converted from ASCII numeric code n.  Example: chr(65) = AZ

ColMax(numbers, break_col, break_value)  Returns the largest value in a column of numbers.

ColMin(numbers, break_col, break_value)  Returns the smallest value in a column of number.

Count(numbers, break_col, break_value)  Counts and returns the number of rows in a column.

CountDistinct(numbers, break_col, break_value)  Counts and returns the number of values in a column.

CountNonNull(numbers, break_col, break_value)  Counts the number of rows in a column.

CountNull(numbers, break_col, break_value)  Counts the number of rows in a column that contain null values.

Cume(numbers, break_col) Returns a cumulative running total for each value in a column of numbers.

Next(c) Returns the next row value of the referenced item c.

Prior(c) Returns the prior row value of the referenced item c.

Sum(numbers, break_col, break_value) Returns the total of a column of numbers.

Statistical Functions

Median(numbers, break)  Returns the median of a column of numbers.

Mode(numbers, break_col)  Returns the most frequently occurring value in a column of numbers.

Percentile(numbers, n, break_col)  Returns the Nth percentile of values in a column of numbers in ascending order.

Rank(numbers, break_col)  Returns the rank of a number in a column of numbers.

RankAsc(numbers, break_col)  Returns the rank of a number in a column of numbers in ascending order.

StdDev(numbers, break_col)  Estimates standard deviation based on a sample. The standard deviation is a measure of how widely values are dispersed from the average value (the mean). If your data represents the entire population, then compute the standard deviation using the StdDevp function.

StdDevp(numbers, break_col)  Calculates standard deviation based on the entire population given as arguments. The standard deviation is a measure of how widely values are dispersed from the average value (the mean). If your data represents a sample of the population, then compute the standard deviation using the StdDev function.

Var(numbers, break_col)  Estimates variance based on a sample.The Var function assumes that its arguments are a sample of the population. If your data represents the entire population, then compute the variance using the Varp function.

Varp(numbers, break_col)  Estimates variance based on the entire population. The Varp function assumes that its arguments are the entire

population. If your data represents a sample of the population, then compute

the variance using the Varp function.

String Functions

Ascii(s)  Returns an ASCII numeric representation of string s.  Example: ascii (“AZ”) = 65

Concat(s1, s2)  Returns text strings s1 and s2 concatenated.  Example: concat (“Brio”, “Query”) = BrioQuery

Initcap(s)  Returns string s with the first letter of each word capitalized, and remaining characters in lower case.  Example: initcap (“santa fe”) = Santa Fe

Instr(s1,s2,n,m)  Returns position of mth occurrence of string s2 in string s1, beginning at position number n. If n is negative, the count is made backwards from the end of s1. If no values are found, 0 is returned.  Example: instr (“Mississippi”,s,5,2) = 7

Length(s)  Returns character count of string s.  Example: length (“Pittsburgh”) = 10

Lower(s)  Returns string s in lower case.  Example: lower (“CD-Rom”) = cd-rom

Ltrim(s1,s2)  Trims string s1 from the left, up to the first character not included in string s2.  Example: ltrim (“Mr. Jones”, “Mr. “) = Jones

Replace(s1,s2,s3)  Returns string item s1 with all occurrences of string s2 replaced by string s3. The default for s3 deletes each occurrence of s2.  Example: replace (customer,”Mrs.”, “Ms.”) = replaces Mrs. with Ms. for all

values of customer containing “Mrs.”

Rtrim(s1,s2)  Trims column string s1 from the right, up to the first character not included in string s2.  Example: rtrim (“Columbus, OH”, “, OH”) = Columbus

Substr(s,n,m)  Returns a portion of string s, m characters long, beginning at numeric position n. The default action for m includes all remaining characters.

Example: substring (“312/989-9989”,1,3) = 312

Translate(s1,s2,s3)  Returns string s1, with each character contained in string s2 replaced by the corresponding characters in string s3.  Example: translate (“12/5/97 3:48:22”, /-,-|) = 12-5-97 3|48|22

Upper(s)  Returns string s in upper case.  Example: upper (“st.”) = ST.

Operator Buttons

Double-click the following buttons in a computed item dialog box to add arithmetic logical operators, mixed expressions, and apply functions to a computation. Operators are added at the insertion point.

Operator/Definition

+

Add

-

Subtract

*

Multiply

/

Divide

( 

Begin sub-operations

) 

End sub-operations

== 

Returns true if the operands are equal.

Example: suppose var1=3; then 3==var1 returns true

!= 

Returns true if the operands are not equal.

Example: suppose var1=3; then var1!=4 returns true

And (&&)
Use the logical operator AND to connect two conditional expressions and retrieve records only if each expression is true, since this determines if a condition is true.  Computed items will not be retrieved if any condition belonging to a conditional expression is false. The AND logical operator is usually nested within another conditional expression, for example, expressions which use if and else statements.  Example: if (OS == ‘Windows’) && (Item_Type == ‘Modem’) {‘Windows’} else {‘other’}

or (||) 
Use the or logical operator to specify a combination of expressions and retrieve records that includes at least one of the expressions.  Example: if one of the words is Washington or Oregon, every record with the expression “Washington” and every record with the word “Oregon” is included.  Typically the OR logical operator is nested within other conditional expression, for example, expressions which use if and else logical operators.

Example: if you want to assign Washington and Oregon to the “Northwestern Region” and all other states to “Other Regions”, you write:  if (State = = ‘Washington’) ll (State == ‘Oregon’) {‘Northwestern  Region’} else {‘Other Regions’}

If…else
if is the only conditional JavaScript statement. It executes a set of

statements if a specified condition is true. The specified condition may be another statement and can include other nested if statements. Brackets must enclose multiple statements.  If the condition is false, another set of statements can be executed if the optional else statement has been included in the script.

Example: if (condition) { statements1 } else {statements2 }

mod (%)
The modulus operator returns the remainder of dividing var1 by var 2.  Example: 5 % 4 returns 1 

<
Returns true if left operand is greater than right operand.

Example: var1 < var2

<=
Returns true if left operand is less than or equal to right operand.  Example, var1 < = var2

>
Returns true if left operand is greater than right operand.

Example: var2 > var1

>=
Returns true if left operand is greater than right operand.

Example: var2 > = var1

not (!)
Use the NOT logical operator to compute and show items more accurately stated in a negative way.  In effect, all records are retrieved except those that fulfill the conditional expression.

You enter the conditional expression with the NOT (!) logical operator preceding the conditional expression.  The conditional expression can be a simple value or nested within other conditional expressions.

For example, expressions using AND and OR. A combined condition expression which uses NOT is true if the condition expression following NOT is false. A combined conditional expression is false if the condition expression following NOT is true.

Example: Suppose you are looking to list all states which are not in the Northwestern region. In this case, you enter the conditional expression:  if ! (State = = 'Northwestern Region') {‘Other Regions’}

Appendix C   -  Print Preview

This appendix covers the following page formatting options:

· Enabling/disabling Print Preview mode

· Adjusting page margins

· Adding headers and footers

· Setting the page numbering

Finishing Touches

Once a report is created, add the finishing touches by adjusting page margins, adding headers and footers, and setting page numbers in Print Preview mode. Before printing, preview the finished report as it will appear on the printed page.

NOTE The Report section does not have a Print Preview mode. Margins, headers, footers, and page numbering can be done in regular mode.

To enable/disable print preview mode:

· On the File menu, click Print Preview.

Page Margins

In all sections, except the Report section, print preview mode must be enabled to change page margins.

All Sections (except a Report Section)

To adjust page margins:

1. Position the cursor over one of the dotted lines representing a page margin. The cursor becomes a 2-directional arrow.
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2. Drag the dotted line to the desired position.  The page is refreshed with the new margins when you click out of print preview and back again.

Report Section

To adjust page margins:

1. On the Report menu, click Page Margins. Dotted lines representing page margins appear in the content pane.

2. Position the cursor over one of the dotted lines. The cursor becomes a 2-directional arrow.
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3. Drag the margin to a desired position.

4. Alternatively, specify the margins exactly. On the Report menu, click Report Setup. In the Margins tab of the Report Page Setup dialog box, specify the exact margin sizes.
Headers and Footers

In all sections, except a Report section, multiple headers and footers can be added to a report. The report does not need to be in Print Preview mode to add them, however, it does need to be in order to view or modify them.

All Report Sections (except a Report Section)

To add a header or footer to a report:

1. On the Insert menu, click Add Header or Add Footer. This can be done in regular or Print Preview mode. The Edit Header (or Edit Footer) dialog box appears. The dialog box provides hot stamp buttons for adding current date, time, file name, page, page total or limit values to a header or footer.
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2. Enter the desired text and/or hot stamps to set up the header/footer, and then click the OK button. The new header or footer is added to the report.

To view or edit a header or footer:

1. On the File menu, click Print Preview.

2. In Print Preview mode, double-click a header or footer. The selected text displays in the Edit Header (or Edit Footer) dialog box.

3. Edit the text, and then click the OK button.

To justify header or footer text:

· Click a header or footer to highlight it, and then click a Justification button on the Format toolbar.
Report Section

In a Report section, there is one page header and one page footer. There is also one report header and one report footer. The report header only appears on the first page and the report footer only appear on the last page.

To edit a report header or footer:

1. On the Report menu, point to Headers and Footers, and then click Report Header, Report Footer, or Show Both. The content pane displays the report header or report footer (or both).

2. Add graphics and fields to a report header or footer.

· From the Graphics folder in the Catalog pane, drag a graphic to a report header or footer. The following graphics can be added:

· Line

· Hz Line (horizontal line)

· Vt Line (vertical line)

· Rectangle

· Round Rectangle

· Oval

· Text Label

· Picture

· From the Fields folder in the Catalog pane, drag a field to a report header or footer. The following fields can be added:

· Field (used for calculations)

· Query Limit

· Result Limit

· Page Number

· Number of Pages

· Page X of Y

· Last Saved

· Last Printed

· Date

· Time

· Date & Time

· Date Now

· Time Now

· Date and Time Now

· File Name

· Path Name

· Report Name
Page Numbering

All Report Sections (except the Report Section)

To set page numbering in any section (except the Report section), the report must be in Print Preview mode. This feature is useful when combining different reports into a single volume.

To set the starting page number:

1. Once in Print Preview mode, right click anywhere to bring up the speed menu and select Start Page Number. The Print Options dialog box appears.
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2. Type a starting page number in the field, and then click the OK button.  The first page in the report is set to the specified number.

Report Section

To set page numbering in the Report section, edit the expression for the Page Number field.

To set page numbering in a Report section:

Select a page number field in a report, and then modify the expression in the Expression line.

"Page "+(PageNm+3)  Starts the page numbering at 4.

Appendix D  -  Computed Items XE "Computed Items" 
Sometimes it is necessary to show data in a report that is not available in the database. The Computed Item feature allows users to create new items by combining one or more functions, operators, or data values. For example, users might create a computed item by combining two existing items, FIRST_NAME and LAST_NAME into one item called FULL_NAME.  This unit focuses on the various ways to create computed items, both by the database server and on the desktop.

Internal versus Database

Computed items are new data items that can be computed locally (internal to the Brio client application) or on the database. Computed items are like normal data items, and can be included in reports or re-used to compute other data. Where new items are created, depends on the calculation required. When new items are created in a Pivot, Chart, or Report section, the calculations are based on aggregated Results data.

When new items are created in a Results or Table section, a new value is created for each row in the table. Essentially, calculations are made at the lowest level of granularity in the document. Use the Results section to create new labels, dates, and values to be used in reports. This is referred to as “massaging the data” in the Results section.

Use the Query section to create equations to be computed by the

database. The list of functions available in the Query section are specific

to the database. A Query section must be connected to a database in order

to view the list of database-specific functions.

The Computed Item Dialog Box

The computed item dialog box is the same in all sections, with the exception of a few operator buttons in the Query section. It is made up of the following components:

· a name field where the name for the new item is specified

· a definition area where the equation for the new item is displayed

· a Reference button XE "computed items dialog box:Reference button"  to navigate to a list of all items available for use in the equation

· a Functions button XE "computed items dialog box:Functions button"  to navigate to a list of database functions (in the Query section) or internal functions (all other sections) for use in the equation; when defining functions, the Functions dialog box alters to allow the user to enter values into fields, which eliminates the need to be concerned about syntax.

· an Options button XE "computed items dialog box:Options button"  to enable the datatype for the new item to be defined

· operator buttons XE "computed items dialog box:Operator buttons to facilitate writing the equation

Reference Items

Use the Reference dialog to insert data items into the definition.  Reference items can be inserted directly into an equation, or added as arguments to database functions.

In a Query section, any item in the data model or Request line is a possible reference item for use in the computed item expression.  In the report sections, any item in the report section’s Outliner is available for reference.

To reference an item in an equation:

1. In a Computed Item dialog box, click Reference to display the Reference dialog box.
2. Double-click an item to add it at the cursor in the computed item expression or as an argument to an inserted function, and then click the OK button.

Functions

The Functions button in the Computed Item dialog box displays:

· Database functions, or

· Internal functions

Database functions are pre-defined functions in a database. Internal functions are Brio-defined functions. Both can be used in calculations. Brio clients support a large number of conditional, date, math, and string functions as well. There may be specific functions that the database supports and the Brio client does not. The reverse is true as well.  Appendix B lists database-specific functions for Oracle as well as a complete list of all internal Brio client functions.

To specify a function:

Click the Functions button in the Computed Item dialog box.

Operator Buttons

To add an operator to an equation:

Double-click an operator button in the Computed Item dialog box.  Operators are added at the insertion point. Appendix B lists the operator buttons available in the Computed Item dialog box.

Query versus Results

When do you create a computed item in the Query versus the Results section? In some cases, it does not matter. Here are some points to consider.

· Computed items defined in the Query section are calculated by the database. Computed items defined in the Results section are calculated internally by the Brio client. If the database supports a function that the Brio client does not, then the computed item must be created in the Query section. If the function is available in both, then there are both options.

· Creating new items in the Results section can be done off-line.

· Often it is useful to make small modifications to Request items in the Query section before using them in new columns in the Results section.

Query Section

In the Query section, Request items can be modified or new items added.  Both are considered computed items. Computed items in the Query section can reference any topic item in the data model, as well as items on the Request line (some of which may be computed).

To compute or modify a Request item in the Query section:

1. Right-click the Request button on the Request line, and then click Add Computed Item.

2. To modify a Request item, double-click it on the Request line.

3. Configure the Modify Item (or Item Properties) dialog box, and then click the OK button.

· Rename the item to reflect the result of the computation in the Name field.

· Define the new item by building an equation in the definition area.

· Click the Functions button to apply utilize database functions.

· Click the Reference button to select topic items and Request items, as part of the definition.

· Use the operator buttons to include arithmetic and logical operators into the definition.

Results and Table Sections XE "computed items dialog box:Results section" 

 XE "computed items dialog box:Table section" 
Many of the computed items available in the Query section are also available in the Results (and Table) section. If the database queried does not support a particular function needed, try creating the item locally, using an internal function instead. One major advantage to creating computed items locally is that it can be done off-line.

Creating computed items is identical in the Results and Table sections.  Both sections can be used to provide new data to the report sections; however, use the Results section to compute new data and reserve the Table section for building tabular-style reports.

Computed items appear as new columns in a Results section. In a computed item, new values are calculated for each row. Data in the Results and Table sections is at its lowest level of granularity. Common computations include:

· Manipulating string values. For example, concatenating a first name and a last name.

· Creating additional date information using the Date Groups feature.

· Creating hierarchical data using the Grouping Columns feature.

To create a computed item in a Results or Table section:

1. Create a query and process it.

2. In the Results or Table section, right-click in the content pane, and then click Add Computed Item.

3. Configure the Computed Item dialog box, and then click the OK button.

· Rename the item to reflect the result of the computation in the Name field.

· Define the new data item by building an equation in the definition box.

· Click the Functions button to apply internal functions.

· Click the Reference button to select items to use in the definition. Reference items are limited to those in the query.

· Use the operator buttons to define arithmetic and logical equations.

· The definition can be manually entered, if desired. Replace spaces in item names with underscores (‘_’).

Refer to Appendix B for a complete listing of internal functions.
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